[Linux] Enabling ALSA line-in device almost never works on my machine ["Solved" by switching to JACK]

So, I have my audio set up like this:

  • Device type: ALSA
  • In device: hw:UR22C,0 (USB audio)

And this set up can lean to any kind of glitches

  • all audio cuts off
  • the DAW slows down to a halt
  • the line-in plugin begins to re-boot constantly (as I see it in the pulseaudio’s control panel) causing an annoying clicking sound

When I set “In device” to “none”, everything works fine.

Have anyone ran into these problems? What could be done here? Thanks!

Please give some more details about distro and its version you are running.

Also, from my experience, jack works without a problem, plain alsa can be problematic :wink:

Ubuntu 22.04, Renoise 3.4.2

I tried jack, but for some reason I/O of my sound card don’t appear there - I can only route midi there.

Are you using plain ALSA, Pulseaudio and Jack, or are you using Pipewire, Pipewire-Jack and Pipewire-ALSA? (Not sure it would change much but it’s still an interesting piece of information to have)

Plain ALSA, Pulseaudio and Jack.

I have used "Alsa " 15 years ago…Seriously

What can I do? I can’t route the line input from my sound card with jack. Jack’s graph only shows “system: capture 1/2”. None of them output anything.

What frontend for configuring jack you are using? qjackctl? You can try cadence or can check if killing pulseaudio (pulseaudio -k) before trying to start jack shows any difference.

Ok, I got it working with Cadence somehow (I see 0 difference with qjackctl’s connection graph but whatever, it works).

It would be perfect, if I figured out how to connect the output to the integrated sound card and the stereo system connected to it, but I guess, it easier to just connect the stereo to the external card.

Thanks!