Linux: lose audio in youtube/browser while running renoise

I installed renoise on ubuntu Studio. When running renoise, I lose audio in my browser more to the point I lose audio in youtube videos. Youtube also ends up freezing up. I have just done a fresh install of of my OS’s. Before I had tried renoise on both Ubuntu Studio and crunchbang and saw the same issue, so I feel it has somthing to do with my audio setup.

Im running on an old Dell Inspiron E1705 with 2gb ram, obviously an intigrated sound card. Like I said I just freshly installed Ubuntu Studio again so everything is shall we say out of the box at the moment. I want to wait to hear any feedback before configuring any audio. Any help would be apprieciated. Any thing I missed that could help determin the issue please let me know.


here is what I see when running aplay -l…

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

When checking Jack I do get the…

Unknown driver “your_backend”

I dont seem to have any problems running say Rythmbox at the same time. Nor do I see any issues while normaly browsing. The issue only arise’s when I try to run any videos in youtube which tells me it may be an issue regarding flash.

I don’t know much about Ubuntu, but it definitely sounds like a sound card driver problem. I have the same problem in windows vista when using the asio drivers for my m-audio sound card.


in Ubuntu ( I am not sure how Studio applies here, but I guess similar) you have sound framework called PulseAudio - generic sound system responsible for most end user oriented apps (browsers, vlc, rhytmbox, and so), while for professional usage - there is a thing called JackD.

Basically, to make beats with Linux you should have running JackD + your DAW (Renoise) using it.

The problem is, that Jack is gonna to lock your sound card to get maximum performance - thus block pulse audio, thus making issues for other apps using same card.

Best solution - grab another audio interface ;)/>/> I have two externals - Traktor Audio + Alesis Multimix 4, both cheap but working great in home setup.

If you are not into buying another interface - you can try to improvise…

For example - most laptops has now HDMI output - which gives you extra audio interface (you just need external monitor to route the signal ;)/>/>

or you can try to route pulse audio trough jack and shit like this:

If you set up and everything will work - you can reward yourself - look picture below.

Thanks for the feedback so far. bluszcz- minus the external audio suggestion I came to the same conclussions last night doing a ton of googling. May try bridging pulse to jack. In the mean time I found another work around. Since I just wanted to run youtube for the renoise tutorials, I downloaded a (linux) package called youtube-dl. I just capture the video and save it to my pc then run it in VLC.

found out Youtube-dl also works for Win and Mac…

I don’t think you mentioned weather you’re using alsa or jack as renoise audio backend, but if pulseaudio applications like ryhtmbox are working fine and only things like flash which uses alsa directly are causing trouble, you only need to route your alsa applications to pulseaudio.

You can do that by editing/creating file called .asoundrc in your home directory (or /etc/asound.conf) and adding this: ```

pcm.pulse {
type pulse

ctl.pulse {
type pulse

pcm.!default {
type pulse

ctl.!default {
type pulse

you also need to have alsa-plugins (or alsa-plugins-pulse on some distributions) package installed.  
if you want to use jack, you need to install jack output (and input if you like) plugin for pulseaudio. i think pulseaudio-module-jack package in ubuntu has both.  
You might also need to mess around a little bit with pulseaudio's config files to make it work, but it might also just work automagically these days :>

Thanks Pus! Yeah I had read that. I believe I even did that before I fresh installed; but then I had done and tried so many things, thats why I ended up re-installing Studio. I’m going to give that a try again when I’m done with this reply.

To answer your question I am using Jack as renoises backend; as well as now configuring most of my apps to use jack.

I that case I recommend installing pulseaudio-jack-modules and there will be no need to reconfigure your apps to use jack.

by default pulseaudio is supposed to load its pulseaudio module instantly to jack when jackd is started and switch to jack output.

If it for some reason doesn’t work that way (it never did for me), or if you want to use jackd all the time and have it started at boot-up, put this somewhere at the beginning of /etc/pulse/ file:

### JACK modules ###  
load-module module-jack-sink channels=2 channel_map=front-left,front-right  
load-module module-jack-source channels=2 channel_map=front-left,front-right  

that makes pulseaudio load its jack modules when it starts. It will also start the jack server if it’s not already started.

WOO HOO!!! I got it to work!!!

so as of today I have renoise running and using jack; and have my browser open and getting sound from youtube, soundcloud,ect.

Here is what I did. I followed the instructions from these three links…

  1. I followed this one till the “$ gst-inspect-0.10 | grep jack” part



Thanks to all who gave feedback. Hope this helps someone else.