LINUX MINT: Auio recording crackling


(oxygenfad) #1

Recording works fine in Audacity. When I try to record in with renoise, I have crackling (as if there isn’t enough CPU). I have Realtime setup, Im using ALSA. I cant get jack to work with renoise for some reason.


(lilith) #2

Please post the info of that script

Does playback work without issues? What interface are you using?


(oxygenfad) #3

I thought the issue was just with my laptop but my desktop has the same problem. I’m using the same usb soundcard.

perl ./realTimeConfigQuickScan.pl
== GUI-enabled checks ==
Checking if you are root… no - good
Checking filesystem ‘noatime’ parameter… 4.15.0 kernel - good
(relatime is default since 2.6.30)
Checking CPU Governors… CPU 0: ‘ondemand’ CPU 1: ‘ondemand’ CPU 10: ‘ondemand’ CPU 11: ‘ondemand’ CPU 2: ‘ondemand’ CPU 3: ‘ondemand’ CPU 4: ‘ondemand’ CPU 5: ‘ondemand’ CPU 6: ‘ondemand’ CPU 7: ‘ondemand’ CPU 8: ‘ondemand’ CPU 9: ‘ondemand’ - not good
Set CPU Governors to ‘performance’ with ‘cpupower frequency-set -g performance’ or ‘cpufreq-set -c -g performance’ (Debian/Ubuntu)
See also: http://linuxmusicians.com/viewtopic.php?f=27&t=844
Checking swappiness… 60 - not good
** vm.swappiness is larger than 10
set it with ‘/sbin/sysctl -w vm.swappiness=10’
See also: http://linuxmusicians.com/viewtopic.php?f=27&t=452&start=30#p8916
Checking for resource-intensive background processes… none found - good
Checking checking sysctl inotify max_user_watches… < 524288 - not good
increase max_user_watches by adding ‘fs.inotify.max_user_watches = 524288’ to /etc/sysctl.conf and rebooting
For more information, see http://wiki.linuxaudio.org/wiki/system_configuration#sysctlconf
Checking access to the high precision event timer… not readable - not good
/dev/hpet found, but not readable.
make /dev/hpet readable by the ‘audio’ group
For more information, see http://wiki.linuxaudio.org/wiki/system_configuration#hardware_timers
Checking access to the real-time clock… not readable - not good
/dev/rtc found, but not readable.
make /dev/rtc readable by the ‘audio’ group
For more information, see http://wiki.linuxaudio.org/wiki/system_configuration#hardware_timers
Checking whether you’re in the ‘audio’ group… yes - good
Checking for multiple ‘audio’ groups… no - good
Checking the ability to prioritize processes with chrt… yes - good
Checking kernel support for high resolution timers… found - good
Kernel with Real-Time Preemption… not found - not good
Kernel without real-time capabilities found
For more information, see http://wiki.linuxaudio.org/wiki/system_configuration#installing_a_real-time_kernel
Checking if kernel system timer is high-resolution… found - good
Checking kernel support for tickless timer… found - good
== Other checks ==
Checking filesystem types… ok.
** Set $SOUND_CARD_IRQ to the IRQ of your soundcard to enable more checks.
Find your sound card’s IRQ by looking at ‘/proc/interrupts’ and lspci.


#4

Oxygenfad: Could I suggest that you find out why you can’t get jack to work and be able to record via jack and see if you still get crackling.


(lilith) #5

There are some parts that can be optimized on your system:

  1. you should set the CPU Governors to performance
  2. swapping isn’t configured yet
  3. sysctl inotify max_user_watches can be ignored
  4. access to the real-time clock should be configured
  5. RT kernel is not needed, should also work good without one

Another thing you can test: Try booting from an AVLinux USB stick. It’s already configured for realtime audio. If it is not working there I guess your interface is broken or not compatible with Linux: