Linux Mint: No Sound On First Note


I’m new on Renoise and I’m trying the demo for the moment. Renoise Runs on a Linux Mint 5 distro. When I start to play, there is no sound on the first note. Same problem when I select “live” the pattern which have to be played after.

I also tried Renoise on a Debian distro and I don’t have this problem. Any idea?


PS : I tried with and without JACK, the problem is the same. And excuse my English, I’m French.

HI Nomis, :)

Im running Mint 6 and Im not having any problems. Have you tried doing the stand alone environment (in the Linux faq) ?

Read the “How can I run a stand-alone Renoise environment?” section. If it runs ok then something in the background of your normal desktop might be fighting for resources.


Thanx for your answer. But I did it and I still got this problem… :(

Any idea?

i also have this problem under windows since some years with renoise, i usually start my song with a empty pattern with a length of two lines.
this will solve this problem.

are you talking about samples or plugin instruments? (or both?)

in my case all; midi-out, vst, sampel. even in render song. the first line is missing.

but(!) not tested with v2 and v2.1 (yet), next week i start a new job so i can test it if i export my songs to midi format (which i must deliver and renoise still no supports :( … ^^ )

I only tried with samples.

It could be a solution, but the problem is the same when I loop a pattern (I don’t hear the first note of this pattern at each loop).

Connect to Ardour through Jack and send all the notes to Ardour to let Ardour record them?
There is also still Xrns2Midi converter using the PHP front-end compiler which should work on Linux as well:

Hey guys.

I found a solution to my problem. I disabled the option “Enable Transport support (master & slave)”. But I thought it had to be enabled to work through Jack?

i use windows and i record it with cakewalk. the first midi note doesnt arrive cakewalk (even tested with cubase). i use maple’s virtual midi.
hmm, a xrns2midi? i’ll test it, thanx !

i tested renoise v2.1 with sample and vst with DX-audio and Asio,
all worked fine, the first line isnt missing anymore ^^ midi-out test next week…

nomis: Which version of jack is installed on Linux mint? Probably that happens only with very old or very new jack impls. We should take a look at this here and fix this if possible.

To find out which jack version is installed, run
“jackd --version” in a terminal please

Ok. I got jackdmp 0.71.

This is happening to me with Renoise 2.1 and Jack:
brian@64studio:~$ jackd --version
jackdmp 1.9.3
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2009 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
jackdmp version 1.9.3 tmpdir /dev/shm protocol 7

This does not happen using ALSA.

Also, disabled jack transport in Renoise options fixes the problem as well. But then I can’t sync with other apps!