Linux: No sound after using Renoise

I’m using Linux Mint (latest version) on my laptop and using Renoise (latest version).

The problem I encounter is that the sound is gone when I stopped using Renoise.

At first everything is working/playing, like youtube videos and other video files or audio files.

Then I use Renoise and there the audio is still working, so I can work with Renoise.

After I close Renoise then I’m unable to play a video or an audio file.

The player (youtube or vlc) isn’t even playing the file, it just opens the file or video and then nothing happens.

The playbar is standing still.

I’ve seen on the ubuntuforum that somebody had teh same problem but he had no solution.

The only thing I can do is restarting the system.

Who knows what the problem is and how to fix it ?

PS: If you want I can make a screencast so you see what I mean.

Maybe: Renoise is starting Jack, and that allows sound from Renoise, but those other applications aren’t using Jack, and are shut out.

I’ve had this happen on my Ubuntu laptop. I had to stop Jack after using Renoise to get the other apps to make sound.

Same problem …

Does anyone know how to automaticly close Jack after Renoise is closed ???

You can use a front end like cadence or qjackctl to start and stop jack.

start renoise with a script that will issue the command “jack_control stop” when renoising is finished. easy if you always only use one instance, but you could also script for multiple instances with some magic.

If it really is jackd in the background - then I wonder how you come about using jack without knowing about it and having it properly configured… and you can also config your system to share jack with your webbrowser, mp3 player and whatnot if you just wanted to… I just switch manually with qjackcontrol, as other audio than renoise or other music production software is bad invitation for procrastination in a sessions that were supposed to be productive…

Other than that - if sound output fails, you could issue in terminal “lsof | grep pcm” to find out what program/daemon is using/blocking your alsa soundcard. Just in case it isn’t jack…

Well I did some testing and I’m not sure if “Jack” is the problem.

I also suspended Pulseaudio while Jack was running like it is described on the Jackaudio website:

Thanks for the tip, I’m gonna try that.

Tried it and I can stop pulseaudi but if I want to start it again then I get the next message:

pulseaudio -D

E: [pulseaudio] main.c: Daemon startup failed.

Quick thoughts: Isn’t pulseaudio set to respawn on most systems by default? I.e. even if you run:

pulseaudio -k

The server will respawn itself anyway. So when you run:

pulseaudio -D

You will get an error, because the pulseaudio server was never killed in the first place :slight_smile:

For example try this command line after ‘killing pulseaudio’:

ps -A | grep pulseaudio


ps -A | grep pulse

You should get no output if you have truly killed the task. Here on my Linux Mint in the file /etc/pulse/client.conf. It is set to respawn:

; autospawn = yes

If that isn’t the case really make sure jackd isn’t running before trying to start pulseaudio:

killall jackd
pulseaudio -D

You are right. Pulseaudio is autospawning.

I’m also using Mint Linux and I looked in the/etc/pulse/client.conf and it’s set to autorespawn.

On my ubuntu system everything works like automagically - if I use renoise with the alsa driver, it steals the sound card completely for renoise, but if I close renoise, pulseaudio seems to notice and audio is back for all other programs. For renoise I usually do use jack, though, and into jack you can integrate a pulseaudio port so you can renoise at low latency & realtime, and other programs can still issue sound via pulseaudio, so you can watch cat videos and worship the caterwaul in those little creativity sags of your usual renoise session.

IDK, you all are using mint, so maybe mint’s pulseaudio isn’t configured to regrab audio after a bad boy like renoise steals alsa devices & you have to bully your distributor or become a whizz and fix it yourself? What does “lsof | grep pcm” say for processes having clinched into alsa stuff like “/dev/snd/pcmCxDxp”?

When I dolsof | grep pcm

Then I get no output.

When I dolsof | grep pcm

Then I get no output.

Yes, chances are you won’t get any output if no music application is using your sound card at the time you run the command andlinux.

Example: Run Renoise, then run the above command. You should see that either Jackd or Renoise (going via Alsa) has grabbed your sound device. Or even run Totem media player and play some mp3, then whilst listening run the command. You might see that pulseaudio has files open to your sound card :slight_smile:

Ok I see it now, may fault.

When Renoise is open and I do that command then I see a lot of lines and jack is there everywhere.

Then when I open an mp3 (renoise is still open) then I see the same but the mp3 isn’t playing.

After I close Renoise and run that command again then I see again a lot of lines and jack is using them.

Something like this:

jackd 7800 and mem CHR 116,3 1689 /dev/snd/pcmC0D0p
jackd 7800 and mem CHR 116,4 1690 /dev/snd/pcmC0D0c
jackd 7800 and 7u CHR 116,3 0t0 1689 /dev/snd/pcmC0D0p
jackd 7800 and 8u CHR 116,4 0t0 1690 /dev/snd/pcmC0D0c
jackd 7800 7801 and mem CHR 116,3 1689 /dev/snd/pcmC0D0p
jackd 7800 7801 and mem CHR 116,4 1690 /dev/snd/pcmC0D0c
jackd 7800 7801 and 7u CHR 116,3 0t0 1689 /dev/snd/pcmC0D0p
jackd 7800 7801 and 8u CHR 116,4 0t0 1690 /dev/snd/pcmC0D0c
jackd 7800 7802 and mem CHR 116,3 1689 /dev/snd/pcmC0D0p
jackd 7800 7802 and mem CHR 116,4 1690 /dev/snd/pcmC0D0c
jackd 7800 7802 and 7u CHR 116,3 0t0 1689 /dev/snd/pcmC0D0p
jackd 7800 7802 and 8u CHR 116,4 0t0 1690 /dev/snd/pcmC0D0c
jackd 7800 7803 and mem CHR 116,3 1689 /dev/snd/pcmC0D0p
jackd 7800 7803 and mem CHR 116,4 1690 /dev/snd/pcmC0D0c
jackd 7800 7803 and 7u CHR 116,3 0t0 1689 /dev/snd/pcmC0D0p
jackd 7800 7803 and 8u CHR 116,4 0t0 1690 /dev/snd/pcmC0D0c

Edit: so after doing “killall jackd” I’m able to play an mp3.

Sir, kill jack :slight_smile: Execute:

killall jackd

(Note: Renoise will not kill the jack server for you on exit, you have to do it manually from the command line (like: ‘killall jackd’) or via a program like Qjackctl)

Edit: Ah, you’ve worked it out sir as I was typing :slight_smile: