Linux: Opening a dialog with zenity from plugins

When I use a plugin that opens a dialog (file selector), the file selector does not show

and renoise hangs. I am forced to kill -9 renoise and start again.

I have seen this behaviour with Dexed and Lua protoplug, so I assume that there may be an issue

with renoise causing this. However I am quite new to using plugins, so there may be something

that I am doing wrong…

Both programs use zenity to show a dialog, for Dexed the command is:

zenity --file-selection --title=Import original DX sysex… --file-filter *.syx *.SYX . --file-filter All files | * 2>/dev/null

It could also be an issue with zenity of course.

I also mentioned this issue I am having with Dexed here:

Note that Dexed works as expected when I just don’t try to load other patches.

I am on 64 bit arch Linux using renoise 3.1.0 b2

Not familiar with linux, but are you sure the selector isn’t hidden behind Renoise? In windows you can alt+tab between programs, maybe there is a similar shortcut in linux which brings the hidden screen to the forefront?

I’m quite sure it is something different, could possibly be my window manager? (awesome wm). I made a small video to illustrate the problem:


When I tried to shut down renoise in the above video it would not close, and I had to kill -9 it.

A log of what went on is here:


Just tried the same thing with v3.0.1 with the same outcome.

Looking at the log file, it seems you are running plugins via the Renoise plugin server. Either because the plugin is 64bit and Renoise 32bit (or vice versa) or because you’ve turned on the “Run all plugin in sandboxes (separate process)” option in the Plugin/Misc preferences pane.

Could you try if this is still happening when not using thesandbox option?

Not saying that this is the solution to the problem, but if that’s what’s causing it, we can dig deeper there.

Just tried again with renoise 3.1.0 b4 and it seems that the result is the same.

When I kill zenity as in the video above I can use renoise again as before.

I copied the log here:


I hipe it helps! :slight_smile:

Tried that with the latest version of dexted from the git repository now too, zenity 3.8.0 on a 64 bit Linux with xfce, but also could not repliciate this.
You said that the zenity process gets created properly but the window isn’s showing up. Are you sure that it’s really not simply hidden - somewhere?

I tried yesterday night, but did not come further. I am using the latest Dexed from github
and zenity 3.18.1 I might try some other options still. However I did conclude that:

  • qtractor shows the same behaviour with Dexed
  • Lua Protoplug also tries to open a dialog and it behaves in
    the same bad way under both qtractor and renoise

Meef Chalion mentioned he also uses awesome wm, so I am suspecting zenity. I’ll have a look at it a bit