Linux: Plugin instrument dropdown doesn't show up (can't load plugins)

I tested Renoise 3.1.1, 3.2 and 3.2.2 with Surge and Zyn-Fusion (zynaddsubfx-vst) from the KXStudio repo on Linux Mint 20.

The 3.2 series is scanning and finding the plugins, but the dropdown doesn’t even activate. When I click the arrow it flashes orange, nothing else happens, so I can’t load them. I tested 3.1.1, as it’s the most recent version in the 3.1 release series, and everything worked as expected. 3.1.1 scanned, found, loaded, and worked with these Linux VST plugins.

Is this a multiple monitor setup or is there some kind of HiDPI scaling involved?

Dual monitor, 1080. Both in landscape (no rotations), one above the other. I’m using Cinnamon if that is at all relevant, too.

I swapped back to 3.2.2, disabled one of the monitors. Started Renoise, the dropdown worked. With Renoise still running I re-enabled the monitor, and the dropdown stopped working again.

Thanks for the info. We’ll fix that. If you move Renoise to the upper monitor, the popup should work too in your setup.

1 Like

Thanks! And yeah, it worked by just switching the monitor Renoise was on.