Linux Renoise Audio And Other Apps

Recently installed Ubuntu Studio 9.10 and while i have most things working OK it is still bugging me in many ways, mainly related to audio and multiple applications.

Now I can get audio out of my machine from just about any application with a bit of messing around. Had to install Jack as it doesn’t seem to come as standard any more.

To be honest I have probably messed things up more than help but trying to follow a few instruction of the 'net, such as this one without being 100% sure of what I was doing (but it is my first install and still learning so if it doesn’t last that long so be it.)

Right, so if I start qjackctl but leave it stopped I seem to be able to use most applications. Renoise works in both Jack and ALSA mode, VLC and Movie Player both give audio.

If I do not start qjackctl then VLC and MP work but Renoise will not see either driver (even though I had the settings of VLC set to use ALSA rather than default so you would think that, if it can use ALSA, then so should Renoise be able to.)

If I start the Jack Server then Renoise works but the other apps will not.

I have just noticed that something I have done recently has stopped the volume controls working and they seem to be set at a very low level as is normal on my headphones with it maxed in VLC (think it’s frozen it at the level it was rather than make it a default, 0 level.)

What I really want is to be able to use multiple programs that want to process audio at the same time, whether it be Renoise while composing then just play a track or two in VLC while I take a breather without having to close down Renoise and tweak other things, or using multiple audio applications at once. I thought I had understood that this is what Jack is for (or at least part of it.) What am I doing wrong? Couldn’t really understand the Connect and Patchbay parts of qjackctl…

OK, so main output level has now been set by the Mater in GNOME ALSA Mixer (is that the best choice out of the three offered? Went for it as has highest “Popularity” out of them.) Still means I can’t use the keyboard Fn+ shortcuts though.

I’m not sure to understand your problem, but here is a suggestion : remove pulseaudio. it is shipped with ubuntu since 9.04 (i think) and it’s another middleware between your soundcard and your apps. Really, you don’t need that.

  1. remove pulseaudio
  2. check your ALSA configuration - it should be alright out of the box, but if it is not, you can run “sudo alsaconf” and let the computer detect your soundcard
  3. run qjackctl (and start jack with it, of course)
  4. run renoise
  5. enjoy

The problem you described previously with qjackctl started but jack not started is weird, but I might have an explanation. I think qjackctl is configured to kill pulseaudio or any sound server so jack can replace it. But if you don’t have pulseaudio, all the better !

  1. if your soundcard is firewire, it’s a totally different problem.

Hello, just to get my twopennys worth in. Ive been using qjack and ubuntu for a good while now and found that it worked quite well with pulse audio. one thing ive noticed though is not enough people install pavcontrol with it.pavcontrol lets you route any program input and output.something which windows is very bad at!.e.g when synaethesia is running(visualization), it normally trys to take the sound straight from my microphone input.pavcontrol will show every program running thats accessing the sound card, be it alsa,esd,oss(pulse audio listens to these types too!!!) etc. you can click on the synaethesia volume meter in pavcontrol and set it to record straight from “movie player” or “rythmbox” or whatever. And as i have two soundcards it also allows me to set what program uses what soundcard with total ease.( ican isten watch porn on the external soundcard with headphones on while david Attenborough is blaring through the speakers…;-)Pavcontrol isnt installed by default but it is in the package manager.I think it should be installed by default, without it Pulse audio does seem no better than other sound drivers.
oh and a tip from me, a useless tramp, run all programs from a terminal for more info abouts whats going on.
you can use vlc with the jackd driver but you will have to search the software repository for the vlc jackd driver. then you will be able to listen too your tracks without stopping jackd.
and on the patchbay…this can be tricky, but the idea of it is that any program using the jackd driver e.g renoise, ardour, vlc, mplayer, will show up here(as long as qjack is running), and with a bit of play you can connect these programs in any order you want.e.g microphone >> renoise >> ardour… but it also allows you too route midi as well. The left side shows programs giving out audio, the right side shows programs with a recording channel. drag an output from the left to the right and jack will connect them.

Oh, and you can ignore me im only just up and have not had my weetabix yet and dont really know what im waffleing about :slight_smile:

As Petit Volcan wrote, qjackctl is supposed to kill pulseaudio. And ALSA is now configured to use PulseAudio by default.
Without having to remove pulseaudio, what you can do is go in the parameters of qjackctl, “options” part, and in the field “execute a script on startup” you can add : pulseaudio -k
(there should already be something like “artsshell -q terminate” which you can get rid of as ARTS is no longer in use).
Then maybe you can make sure qjackctl parameters are correctly set. Especially the sound device in case you have multiple soundcards.

I don’t find qjackctl’s patchbay very easy to use. Basically you’ve got to launch your programs first and then connect them into the patchbay. For example you can load Hydrogen and put it on renoise IN. Then add a line-in on a renoise track, and you’ll hear the hydrogen output.

About being able to use multiple sound programs at once, if you want to use jack I think you’ll have to set it up that in your global system parameters. VLC (and other programs) will then use jack by default.

how do you do set the system to use jackd by default?

Thanks for the replies people.

Managed to get Renoise and VLC together with the jack plugin for VLC. Just about got my head around the patches (pretty easy once it’s actually got some applications displayed.)

Although both Renoise and VLC are set to use Jack they will both work without me running qjackctl and starting jackd. Is this because they default to another driver? ALSA? Renoise seems to claim it is using Jack as it usuaully gives an error message if it can’t access it.

Seem to have broken something with PA and can’t get it to run so can’t get any sound through my Firefox at the moment, which is a little irritating.

Trying to kill PA gives Deamon not running, trying to start pulse-session fails too. Not sure what to try to see what the fault is here.

Currently running onboard sound (Intel HDA, although most other systems call it Realtek.) I do also have a firewire soundcard, built into my M-Audio Ozonic which I do plan to try and use at some point as it gives me less noise issues than the onboard.

this is what I hate in Linux the most: they are still adding stuff without taking real care about what to do with backward compatibility. If I could decide about this, I would completely remove EVERYTHING related to ALSA and OSS from new distros, while they are still pretending to make ALSA, OSS, PulseAudio and JACK applications work together.

PulseAudio is surely the way to go for the standard user, and JACK for the audio user, but they should just trash the past if the want it to be working.

I know that PulseAudio uses ALSA as a base, but that’s not my point: PulseAudio should have its own audio driver which is simple for the audio application to use, and if an application does not get updated in order to use it, it will not be added to the new edition of the distro. I would make it as simple as this for an audio specific distro; it may seem a fascist approach, but still better than anarchic.

Jack also needs a back end such as ALSA or OSS doesn’t it? The part that actually communicates with your sound chip.

yes, it is the same as for PulseAudio: in my opinion, they should start the whole audio stuff from scratch, while it looks like the most ignored part of Linux.

Have you ever tried to do some ALSA configurations other than the standard ones which come with the installation? it is a nightmare: I tried to do it because I wanted to run PulseAudio under JACK but failed miserably and I’m not going to try that anymore.

In general, if the Linux installation manages to enable audio for your PC, then you are lucky, otherwise it’s better to skip Linux.
And if you need to get out of the standard (like for example if you want to use Renoise together with other applications), there are high chances that you are going to mess your sound configuration completely.


I’ll give it a little while, maybe I’ll even compose something in Linux ;) but not quite convinced with sticking with it at the moment…