Linux Studio Plugins/LSP graphics freeze


I stumbled upon this project:

A set of studio plumbing plugins in different formats for linux. Plain but yet clean sound. Interesting things in there, upwards compressor which are rare, a real smooth but heavy sounding lookahead limiter, etc.

Not I have some problems using the lxvst 64bit version together with renoise 3.1. on xubuntu 16.04

When I add them, initially everything seems fine. Though I already feel like whole renoise is getting a little blocked up, it is not really the audio load that seems to cause it.

Let’s take the stereo limiter as example, this is the plugin I want most, the other plugins have the same behaviour. As soons as audio is running through it, the gui window gets almost completely unresponsive, sometimes it updates in irregular intervals of some seconds, sometimes opening the plugin gui takes ages with a grey window until it displays anything. When it gets only silence as input, things resume to almost normal state. Sound goes through kind of like it should though. When I tried to render a tune with the limiter on master (or premaster send), there also was a little glitch in the beginning of the render, a complete little nasty gap.

In this state the plugins are pretty much unusable. I’ve tried the usual plugin options and sandboxing, nothing seems to help.

As comparison I tried loading a wav track into ardour and slapping the same limiter VST onto it, it works very nice, gui is fluent, just as it should.

Could you have a look at it? I mean there must be some difference between ardour and renoise that causes this messy behaviour. I’d really love to have these plugs in my arsenal! Thank you.

I use these plugins a fair bit and haven’t experienced the same problems. It may be worth reporting it to the LSP dev, he’s very responsive and quick to fix any bugs that might crop up. I read some similar sounding issues about the gui under mixbus and bitwig here.

Ah thanks, as the dev is active there, I will chime in into that forum to see if it can be fixed…

out of curiosity what linux distro and version of those plugins are you using with renoise 3.1 without problems?

I’m using kde neon (so same base as you). I just realised I was using 1.22 so I updated to 1.23 and still seems to be ok for me unless I just can’t hear the artifacts, certainly doesn’t seem to be anything very obvious and I don’t have any issues with the gui.