Linux Tune-Up


I run 64bit Crunshbang Linux (Debian).

I allready sucessfully installed full Renoise 3.0 and Milkytracker, Audacity.

(I am using Renoise on Windows 8.1.Pro, 16GB RAM, QuadCore - but want to have it on my linux PC too)

Renoise runs pretty good. Everything seems working

but crashes on “too much CPU” is using on every second …

I have add to:


@audio - rtprio 95
@audio - memlock unlimited
@audio - nice −10

So I have no “realtime priority” error during loading…

I have tryied to put lower latency or sample rate (but soundcard accepts only 44khz and 48khz)…

What I should to do?

Buy PCI-e soundcard? Which one is best for Linux?

Or more RAM? I have only 2GB…

My Linux Setup is:

CPU: 4x 1,6GHz Intel (ATOM)


Debian Linux


Have you checked to make sure the cpu frequency scaling is set to performance? I believe most distros come set as “ondemand” which really affects playback.

There’s different tuning options for linux audio. I’d recommend experimenting with the jack server to get a feel for it, and watch the x-run meter, renoise audacity milky are btw all able to run in a jack environment.

But you haven’t really described your problem well. Just a “too much cpu issue” won’t settle this down - i believe renoise would spit that out when it’s dsp use up too much cpu ressources? Will this happen with tracks full of fx, or in empty tracks with, say, just 2-3 simple sample instruments? An keep in mind the atom is a really, really weak processor - it’s 1.6 ghz even get diminished by it not featuring any instruction reordering and such. Have you used a cpu monitor (i.e. htop) to monitor processor usage under such conditions, or wether there are other processes in the background eating away cpu power?

Common causes for dropouts I’ve experienced are: ondemand governour instead of one with constant clocking (performance), you can change the governor, or disable reclocking in the bios. Graphics card drivers can bug out a lot, too, expecially the proprietary. Or other interrupt sharing and drives issues, wifi chips are prone to cause mayhem with audio. Wrong settings for the soundchip, some like certain values best - what buffer sizes are you actually using? Then it could be you have a shit onboard sound chip, that just won’t like realtime action. General obscure bad luck with the hardware is another thing that can happen with linux.

Things I normally consider are: realtime priorities for the user (are you already in the group “audio”?), usage of a “lowlatency kernel” (but ubuntu’s generic works ok for me atm), softirqs / rtirq script action (can counter probs with graphics card drivers, interrupt sharing and such), downing background processes, using a desktop environment without too much bling. I’m using jack at 128 frames/period, and could go lower, x-runs only sporadically when programs that connect to jack or plugins are started. With an hda intel shitsoundchip, but I also have an old m-audio audiophile lying around, and remember it from using in another pc to be even more stable in realtime action, having lower latency generally (very little “hidden” delay compared to the hda stuff), and audibly better sound quality.

Hi, I also have a quad core i5-3570 CPU @ 3.40GHz with 16G RAM and a M-Audio 1010LT audio interface card. Am running Linux Mint, not the latest (Ubuntu-based).

The way the limits.conf is setup is that it uses a limts.d/ directory. So in this limits.d directory is an audio.conf file that contains the following:

@audio - rtprio 95
@audio - memlock unlimited
#@audio - nice -19

I guess you could put these into limits.conf too. I like the distinct approach though.

The nice was commented out. I say ‘was’ because I did that a long time ago and do not recall the details of why. Nevertheless, I run qjackctl at 44.1, Ardour, Renoise, Qsynth, Zyn synth, jamin, and rarely get xruns. I often have many audio tracks in Ardour and Renoise is sync through jack. Everything is smooth and does not produce any annoying problems that would distract from the main thing: creating music.

So only the nice is different. What kind of audio interface do you use ?

btw. to test rtprio and memlock settings, run the command “ulimit -r -l” in a terminal as the user you’re starting all the audio programs with. It should output “95” and “unlimited”.

But I guess the culprit would be elsewhere in the chain, even without realtime priorities you should be able to run audio tasks without too much cpu usage, it’s just not very stable (you’ll get dropouts) and other programs running on the system can easily block cpu ressources for the audio task (leading to even more dropouts).

Have you added your user to the audio group?

I run Renoise on an X220 laptop running Xubuntu.

It had weird CPU performance problems I didn’t understand. It was under performing.

My solution:

$ sudo apt-get install indicator-cpufreq

Then reboot.

This puts an icon in Ubuntu’s appmenu (upper right). Select “Performance” (or top CPU speed) when running Renoise, problem solved.