Linux VST instruments don't work

I’ve tried: Dexed, Oxe, Aspect, Tunefish, and others. Vertigo was the only one that worked. Vital worked but crashes the DAW when you try to close the plugin window

I think you need to provide some more info regarding OS version and renoise version that you are trying to use. Also if you are trying to run vst2 or 3 and if those plugins you tried were working in other daw lets say Ardour for example.

1 Like

I tried on all major distros, Fedora, Debian, Ubuntu, both VST and VST3
I’m using the latest Renoise version
I tried some of these same plugins in Reaper on Linux, they worked. But I didn’t test all of them in Reaper

Thats very surprising as i have no problem running any Linux vst on renoise on both arch and ubuntu. Do you experience some particular error or plugin dont show in renoise at all?

Some don’t show at all, like Tunefish and Oxe. Some show up but don’t load, like Dexed
There were others, but I don’t remember all of them

Tested once again with Ardour and Reaper, just in case. 5 synths. Oxe, Tunefish, Vital, OS-251 and Dexed
On Ardour, only Vital and Oxe worked
On Reaper, Oxe, Vital, OS-251 and Dexed worked
So, it seems Linux VSTs not working is more than just a Renoise issue. I was honestly expecting much more from Ardour, supposedly the flagship FOSS DAW

Ok, and currently you tested this on what linux/version? And synths was installed with package manager or downloaded .so from internet and copied into .vst/.vst3 directory?

Ardour focus is on mixing BTW, thats why it is used as a base for Harrison Mixbus. I can totally agree that MIDI part of it sux.

Debian Testing. Synths were all downloaded from developers’ homepages, no package managers
Here I found 2 videos showing Dexed and Vital working just fine in Renoise on Ubuntu… Jacob Devine - YouTube

Because it does work, as i said i have no problem with any synths, thats why im curious about what setup you have. Maybe check if in renoise properties you have enable “VST_PATH” and “VST3_PATH” and both those envs are set up in your profile env|grep -i vst.