Linux: ZynAddSubFX VST crash

On ubuntu 19.10 yesterday this happened and when i load again the project the vst goes to the default preset and i cant remember the preset name to continue my work

vst crash

1 Like

Ooh I hate that. I had one years ago that didn’t save the presets every time I load the song and it was incredibly frustrating

Is there any way i can find the presets used before the crash,does renoise store somewere the settings?

Must be in the song.xml file when you unzip the renoise file.

I checked but it says (Default) in all the plugin entries in the xml.I guess i will have to save manually the presets next time to be sure i dont lose them

VST parameters are usually saved in renoise xml in a way specified by the plugin. look for the <ParameterChunk> cdata blocks, maybe you could transplant into a working song.xml to recover the preset? looks like garbled stuff, binary converted to text.

But maybe it is just that preset, that crashes the song file :frowning:

It’s a very faulty plugin this one even when it don’t crash when you have it open and choose a preset,if you close it and open it again it does not show the preset.

Sorry I had the brackets in my post hidden - there must be a ParameterChunk block somewhere in the instrument. There is the preset data - maybe it can be copied into a sane copy of zynadd in another song.xml to recover the preset?

Where do you have the zynadd plugin from? I have mine from kxstudio, seems to run well - I just have to get used to the new interface, so I haven’t worked with is a lot yet… Would be a pity if they have made it unstable…

1 Like

This is the version i have from kxstudio and the xml if you like to take a look

Song.xml (1.2 MB)

I also have the Kx version and sometimes it crashes, yes.

Hey good news, I managed to transfer the preset data into another .xrns file by copy/paste the ParameterChunk data between the song.xml…

This the sound you were looking for? .xrns loads fine with my version of zynadd, and it is some fmish clavinet type of sound…

tst.xrns (7.9 KB)

1 Like

Thanks for taking the time to help me but i get the same error when loading this,also in my project file i have 7 instances of ZynAddSubFX so its not one present.Can you see the actual preset name and if not can you sample it and give it to me?

Oh I see it is 7 instances, I just copied the first… :flushed:

I could load your song, it does not crash, it plays fine, all 7 zynadd have their sound.

The preset names in the interface are:

00 BASS 4

P.S. for another plugin I had plugin sandboxing enabled in the preferences. Maybe that makes zyn load the preset. hth


Oh my God it works!!!Sandboxing so far does not crash plugin and the presets you gave me are working too!!!I cant thank you enough but tell how did you find the presets cause i have this plugin on other songs and i cant bother you every time i have this problem.Explain to me how did you do it.This song will be dedicated to you when i finish it

Glad I could help you.

I just open the plugin interface. Then the name is in the “Name” field. Here I marked it on a screenshow for u:


Ok thanks but I ment how did you copy the data from one xml to another?

With a text editor :-p - xml is just text data after all.


So i copy all the XML data to a new one and put it in the song folder?

You need a valid song.xml inside a zip file (renamed to xrns) - then you can try to load it as song in renoise. I just did so with your song.xml file. And yes, you can copy/paste certain stuff between the xml files. Exchange sections, replace the “ParameterChunk” block with that from another file, stuff like that. The data just needs to be in proper shape so renoise can load it correctly…


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.