LinVst - Vst instruments listed as effects

I’ve been trying to get some vst’s working under linux using Linvst.
So far some of them work, but all the instruments only show up in the effects list.
How can i tell renoise they’re instruments?

Thanks (a lot)

Hi, I’ve been using linvst on Manjaro for some time now, and it happened to me too on some plugins.
What you can try is putting the incorrectly listed VST in an effect chain. Renoise should complain that the plugin was badly registered as an effect instead of a synth, and IIRC, a restart of Renoise should then correctly register it as a synth.
I also had issues when using mainline Wine that were resolved by installing Wine-staging instead.
Maybe it would be helpful if you told us what version of Wine (staging or not?) and Linvst you’re using.

Hmm, Eventho i recently switched to yabridge instead of linvst… i never really experienced this, with which vst’s does this happen?

What version of linvst are you using?I used the 2.8 version with no problems,newer versions gave me problems


Choose the sandbox option for plugins.

Sometimes a synth vst might not declare itself as a synth and Renoise might not enable it.

A workaround is to install sqlitebrowser

sudo add-apt-repository ppa:linuxgndu/sqlitebrowser-testing

sudo apt-get update && sudo apt-get install sqlitebrowser

Add the synth vst’s path to VST_PATH and start Renoise to scan it.

Then exit renoise and edit the database file /home/user/.renoise/V3.1.0/ CachedVSTs_x64.db (enable hidden folders with right click in the file browser).

Go to the “Browse Data” tab in SQLite browser and choose the CachedPlugins table and then locate the entry for the synth vst and enable the “IsSynth” flag from “0” (false) to “1” (true) and save.

© LinVst README :wink:

btw, just wonder what plugins you have tested?
I have tested about 2000 plugins and never seen that :upside_down_face:

1 Like

Thanks a lot for your answers :slight_smile:

I’m using linvst-bin 3.15-1 (upated from something 2.8ish, as it once worked semi-well and then stopped working entirely a while ago),
also on Manjaro.

Just installed wine-staging instead of wine, but that didn’t work.
Also i’m getting an error about lin-vst-servertrack32 not working.

Yeah reading the readme… might help aswell, wonder why i didn’t^^’
The SQLite Browser though very useful didn’t work too, setting IsSynth (some of the plugins had the variable set right from the beginning) just makes the plugin disappear from the effects list but they dont show up in the instruments list either (it’s empty).
Makes me wonder if the problem isnt somewhere else, as dexed which shouldn’t depend on linvst doesnt show up as well.
I maybe should try to reinstall renoise.

Does Yabridge work well?

'Creepy Piano
Super Spook Keys

Yeah you should try to remove Renoise, kill all configs (backup just in case) and start from scratch, i have most of plugins from your list and they doesn’t have your problem…

Also 2.8 should still be perfectly working under current Manjaro Stable btw, i use it for testing purposes a lot (compile from source, use Makefile-64-32bit)

And i use plugins in non-system wineprefix with non-system wine-staging x64 version, to try and be as independent as it’s possible from actual system :upside_down_face:

Does Yabridge work well?

No idea, you can try :wink:
For my needs LinVst is by far best completed with LinVstManager

Yabridge works really well for me, and its really actively developped…
It has a sync function which automatically creates .so files for you…
At least, so far i am really happy with the switch…