Liquid Mix in 64bit Renoise - CPU problem

Update: Fixed!

Original Problem:

I’m just trying out my old Focusrite Liquid Mix unit with Renoise. When engaged, a single instance of the Liquid Mix is showing about 30% CPU (this is a monster i7 machine).

It’s a 32bit VST plugin that provides an interface to an external firewire box with all the DSP in there.
In Renoise 32bit I am seeing less than 1% CPU hit which is similar to the CPU hit I am seeing in Reaper 64bit.

So I’m guessing there is something going awry in the Renoise 64bit bridging.

Fix: I just uninstalled the liquid mix drivers on the problem machine then re-installed them. The problem was solved. Strangely both machines had the same version number installed. I remain unclear about why it happened.

Hmm… interesting.

I tried the same thing in my home setup just a moment ago (last post was from work) - it works perfectly on my home setup.
I’ll try and use occams razor a bit over the next few days and see if I can narrow down to something specific.