LoopMix VST3 crash, when loaded in songs/instruments in Renoise 3.4.3

Getting a fatal Crash, if loading a previously saved song that used “AudioModern Loopmix” VST3 Plugin. It workes without crashing on previous versions like 3.4.2.

I’m on Windows 11 Pro 64bit.

Screenshot 2023-08-07 174651

I can’t replicate this crash in a new Song using the latest trial version of Loopmix.
Does this always happen for you, also in new songs?

Hi taktik,

yes it happens everytime. My steps to replicate are (just tested again):

  1. Start Renoise 3.4.3
  2. Choose Loopmix as Plugin as Instrument
  3. Choose a Preset in Loopmix (Optional, it will crash with init status too!)
  4. Save the Song
  5. Re-open the song and it’ll Crash

I’m using Loopmix 1.1.2
Screenshot 2023-08-08 181751

If I open songs previously saved with 3.4.3 in e.g. 3.4.2, they open just fine without crashing.

Hope it helps identify the culprit.

Edit: All other VST3 I’m using work fine in 3.4.3, its just Loopmix so far

Are you on Windows or macOS?

I’ve tested exactly the same thing here, but with the trial 1.1.3 vversion.
Could you please try if upgrading to 1.1.3 fixes the problem for you?

If not, I’ll ask the audiomodern crew for help.

*Ouch! Embarrassing, the information that LoopMix 1.1.3 was released must have slipped through.

I installed it and the crash is gone. I guess gg case is solved!
(I’m on Windows 11 Pro 64bit)

Thanks for your time and help!


Glad to hear that this is solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.