M-Audio Oxigen 49 MK IV "the nightmare"

Hello all, I’m hoping to find here some kind of clue to end a nightmare I’m experiencing.
It started 2 weeks ago, when i decided to buy a new Oxigen 49 MK 4 . I had the Oxigen 49 Silver for several years before and it always toured with me and worked fine each time so with confidence i bought the MK4. Plugged it in and it worked after a few hours i could hear the typical sound of a USB device disconnecting and immediately after reconnecting this kept on happening and the keyboard was unusable. Thinking it was a faulty units i returned to the shop and i was immediately sent another one. This one same story, it couldn’t hold a connection. I looked at everything, browsed various forum and saw with disappointment many users experiencing same problem. I tried all the various fixes suggested in the forum and when i say all I mean all. Nothing made any difference. I then spoke to the m-audio support here in the UK and after 24 they responded to me with an email telling me that the problem exceeded the level of support they offered, they suggested for me to back up and reinstall the operating system or contact Windows that they might be able to help me. I tried to connect it to another PC, in fact a laptop and it has no problem. So why does it have a problem with my desktop? and why it didn’t have a problem when i first plugged it in to the same desktop? I am not going to format my HD and start installing everything only in VST it would take me forever and i probably would lose all my settings and files . I simply can not believe that I bought a keyboard new and I can’t use it and no one can tell me why. The desktop works very well I run several other usb devices and i have a 65o wts power supply using maybe 350 wats at the moment. I am stuck, i could buy another brand keyboard but what if it gives me the same problem? I cant believe that I have to keep making my music without a keyboard because M-audio can not or will not support their product.
thanks for reading

Check your power saving options especially for USB.
This green deal irritates me in linux too.
I give “usbcore.autosuspend=-1” first in my grub.conf
I don’t know where to set in Win :frowning:

checked all power saving all disabled as suggested in all other forums. Nope thats not it like i said I tried all suggestions in sveral forums I am totally discouraged.

Then dunno :frowning:
Maybe you can try some live linux distro.
Maybe you can connect multimeter to usb port and check power.
Hard to say

Are you sure that you have installed the chipset drivers correctly on your pc?Remove them and reinstall .Also does the problem occur on other usb ports?

Maybe adding/removing a powered/unpowered usb-hub helps as a workaround? Perhaps in the same/a different power outlet.

Oh, another (ugly) workaround, maybe, insert a usb-over-utp-cable extender.
All long shots though, usb even in 2020 has some magic attached.

I have an expensive d-link usb hub that does the same (perhaps less after the windows reinstall, and more when starting Steam, weird…) I stopped using it on that particular (not earthed) computer.

(sidenote: a windows reinstall can do wonders though)

That got me thinking, a raspberry Pie with RTP-midi will most likely work around issues like this.
If the RPI maintains the usb connection that is.

A windows reinstall would not do anything. I booted the PC from an old Hard disk I have by simply inverting the hard drive boot order in the BIOS, it made no difference. Instead, It’s been two days that I’ve been toying with an idea I had. What if it is an earth issue? The randomness of the disconnection and reconnections indicate a surge of static of some kind. I looked at the inside and sure enough i found an earth cable connected to the frame but just sitting there not connected to the motherboard. Probably that last idiot that sold me a new ssd drive and installed it disconnected it and forgot to reconnect it.

yep, installed it two times from the original motherboard disk install and the latest version from the asus website. no difference.

When you go to the device manager in windows do you see any yellow marks ?,that means that drivers didn’t install correctly.Did you install any other drivers recently like for your audio interface etc.I suggest going in safe mode and uninstall all the drivers .Safe mode will ensure that drivers are completely removed.Also when you reinstall the chipset drivers make sure windows is not connected to the internet.First download the chipset drivers from the manufacturer site then go to safe mode uninstall all drivers then reboot to windows with no internet install the drivers, reboot again go to the device manager if there is no yellow mark anywhere you are good to go.Pay special attention to the display/monitor tab it must show the correct name of your pc screen