Mac: Cannot start the demo

Hi,
I downloaded the demo to see if this was my workflow, but when it was downloaded and all seemed well, i got signal 11 when i ran it from my terminal. Is there anything i can do to fix this because it would very much like to try and maybe buy Renoise!

Hello,
What does the command ‘strace renoise’ print when you run it from the console?

WARNING: One or more duplicate entries found in your codefiles, which will lead to unpredictable decoding behavior. Re-run with -v for more info

This is with “trace” because “strace” wasnt found as a command, dont know if it was a typo or not.

Sry,
When you wrote ‘from the terminal’ I automatically meant linux :slight_smile:
Somehow I missed ‘Mac’. I can’t advise you on that :frowning:

Not your fault, it was automatically put on Linux and I later(after you posted your reply) changed it to Mac.

Have a good day!

What macOS version are you using?

Does the same thing happen when you run it from Finder?

Is there a Renoise.log file in you users log folder?

macOS 13.6.4

And I think there is no log.

Hey, I’m running into the exact same issue on MacOS 14.5. The demo won’t open from Finder, when I tried to run the executable in the .app I got the same error. I clicked allow on the security popup first time I tried to run the program. There’s no logs in ~/Library/Logs or in /Library/Logs

Perhaps the demos of the latest releases are somehow broken.

Does this version work for you? (from the previous release)
https://files.renoise.com/demo/archive/Renoise_3_4_3_Demo_OSX.dmg

There is also a problem with the licence agreement not being displayed correctly. Probably something went completely wrong when building the latest version. I’ll investigate…

Yep, that launched and worked perfectly fine for me, thanks!

YES, it works! thank you so much! :grin:

Gewoon nog een Nederlander, lol

@lalatracker123 and @komkommer

I’ve fixed the broken licence thing and something else in the latest demos. Could you please quickly check if the latest 3.4.4 builds are working for you too?

You can download them here: Downloads | Renoise

Yep, it works fine now. The licence agreement shows up and the program starts.

Yes it works for me too.

Thanks for checking!

1 Like