Mac: Image Line Drumaxx Gui Not Working...

Hi, Image Line Drumaxx is not working correctly with 2.6 b3 in OSX 1.6.4 Intel machine.
A GUI problem affects the whole correct operation(the “Enable keyboard” option and “randomize button” doesn’t apperar in the bottom’s horizontal bar, the horizontal bar appears in white in the top, causing the problem) .
You can install the demo version to try it.

I just ran into this bug today (or maybe the bug is with Drumaxx?). It seems the horizontal white bar you mention shifts the GUI down, but the “clickable” areas stay put throwing everything off. No one else has noticed this? Or maybe it’s just us two that use this plugin around here. :P

i use it with no problems,although i have to say i think its not very good…

Hmmm, I’m guessing you’re using Windows? The OP and I are in OS X. I’ve tried both AU and VST versions so maybe it’s an issue with the Mac version.

Could be the difference between ppc and universal build…
How old are those plugs?

If memory serves me correctly, it was released earlier this year sometime in February. On the product page, in terms of OS X requirements, it notes “Intel CPU or G4 PowerPC (Mac) with full Altivec support.” Not sure if that’s a clue to anything.

Here’s how the plugin window looks. The “Enable Keyboard” and “Randomize” controls are gone from their usual spot at the bottom. At the top, the light grey bar that’s 28 pixels high pushes the GUI down, so in order to tweak controls you’d have to click 28 pixels above a control’s graphical representation.

Image-line plugins sucks on macosx in general, acts the same under reaper - also Biohazard

Well, that fact will rule this out then. Adding Parasonics perceptions to this scenario, clearly the finger seem to point towards the plugin itself then.

No offense to Image-line stuff, they work great on pc, my frustration is caused by lack of plugins like Drumatic on mac (freeware, semi-freeware) and Drumaxx look very nice on paper.

I am having this exact issue, but only in Renoise. I don’t use Reaper, so I can’t comment on that. But the plug-in works just fine in Numerology, in Live, and in Logic Studio. Only in Renoise do I have this issue.

I’m also opening an issue with Image line on their forums, but I would really appreciate it if you have the time to revisit this issue and take a closer look at it in light of the evidence above.


OSX Snow Leopard version 10.6.6
2.5 ghz Macbook Pro
Renoise version 2.6.1
Drumaxx version 1.2.1 (latest version)
Happens in a clean song

Remedies tried:

  • reinstall plug-in from scratch
  • Check the “Use static buffers” option in Renoise
  • Uncheck the other two compatibility options in Renoise

Update: I just downloaded and installed the latest demo version of Reaper. (3.75)

Drumaxx works in both VST and AU form in Reaper without any problems for me.

An odd prob I’m having with image line stuff is that part of the GUI (background) for Sytrus shows bits of some other image line plug… one of the samplers (directwave, i think? i don’t use it…). I’m not sure what this means to the thread except that your prob + mine makes it kinda seem like image line has a prob with the vst version of some of their plugs?