Mac vs Linux (Renoise performance)

Hi.

I currently have an old but kickass computer (16gb - i5 quad core 3,5gHz - good GPU…). Meaning I should be able to run 2 separate Renoise instances with 10ms latency while playing CS:GO and still plenty of power left.

But it’s not the case. One renoise with 4 tracks (only samples and effect chains - no vst) 16ms - And I got XRUNS. Every once in a while “gzz”…“gzz gzz” : that’s the sound of the computer not keeping up.

I run linux. With CCRMA low latency kernel.

SO. Question : would switching to mac improve this situation ? Is there a difference in stability and performance between the two ?

You shouldn’t expect xrun free performance on Linux out of the box.

There’s some homework to do first (rt kernel alone is not enough):

http://wiki.linuxaud…tation_on_linux

Then you can use the Quickscan script to verify your config:

https://github.com/r…configquickscan

This was already discussed in great length:

https://forum.renoise.com/t/linux-priority-too-high/46124

https://forum.renoise.com/t/low-latency-and-xrun-optimizations-on-linux/45002

But yeah, it would be interesting to hear from Mac (and Windows) users how low they can go latency wise - just to have a reference.

Thanks. I know this too well so the question ends up being “should I work my arse off to make it work… or to get the money to pay a mac”.

Here I’m stuck with

"** Set $SOUND_CARD_IRQ to the IRQ of your soundcard to enable more checks.
Find your sound card’s IRQ by looking at ‘/proc/interrupts’ and lspci. "

Which I was certain I did… But apparently wrong. And on top of that the nvidia driver broke once again after an update.

It makes you think you know :slight_smile:

Well, not sure if paying for a mac would help you actually, it highly depends on what you’re using inside Renoise.

Some internal effects trigger xruns like crazy, like the cab simulator for example. Redux instruments can also be particularly heavy.

To take an informed decision, I guess you would need to cook a test file including the stuff you use usually on the different platforms, then ask folks around here to run it at various latency settings and report back (with HW specs).

I could give it a try on my config, but only on LInux and with wimpy HW I’m afraid…

Well. One good way to test would be : is the cab sim a problem with all platforms or only linux ?

which distro/version? this is important to know in order to be able to give tips on the right steps. it is easy to find borked tuts on the net that are overly complicated, wrong for the distro/system, will break on updates, etc.

are you running renoise via jack or alsa?

what kind of soundcard?

how many threads have you assigned for each instance of renoise, you said on a quadcore cpu?

have you activated realtime privileges and memlocking for the user running renoise and jack?

what are the jack settings if you are using it?

are you using the rtirq script, and if so, what have you changed to the priority order?

yes, the cab sim glitches renoise on sub 15ms latency via jack on my system when switching the amp type, but when just running a config it won’t cause deep problems for me.

You’ll find all the data in here : https://cm-mail.stanford.edu/pipermail/planetccrma/2016-May/018603.html

Yet it’s drifting a bit from the main subject. I’m still unsure whether it worth the hassle or not :S

If you are used to linux you should stick with it, imho. It really depends on your distro, I think. I’ve been running for 3 years an arch linux installation consisting of a ck-patched kernel, jack2 (with jack1’s synchronous server mode enabled, yes), and wine-rt (now wine-staging) on my 2011 mid-specced asus laptop. Played a bunch of times live with ~0 xruns triggering samples (playing “electronic drums”) or proccessing incoming audio and synthetizing stuff with renoise+supercollider.

If I could go with an OS doing a lot of background stuff while I try to work, I would prefer osx over windows. That’s not my case.

I have a question though: 16ms or 16 samples? The later is pretty insane but still achievable, I think one of the guys who commented before me uses a setup that goes around a small buffer.

Oh, also. What about money?

You’ll find all the data in here : https://cm-mail.stan…May/018603.html

Well, the goal is to read it by yourself - for each failed steps it gives you hints on how to fix it (might need to be adapted for your distro).

the main issues are apparently:

  • cpu governor is set powersave and not performance -> fix that first

(think about a WV engine passing an emissions tests vs full throttle on the German highway).

you can try “sudo cpupower frequency-set -g performance”

  • no rt kernel (either because the ccrma low latency kernel doesn’t have the rt patch or because you didn’t boot from it).

Better have it, but it is not as bad as it used to be. You don’t necessarily need an rt kernel those days - that becomes really useful for sub 5ms latencies.

The rest is either for midi or minor.

Your soundcard is on irq19, but I don’t think there’s an issue at this stage, like the rt kernel, you shouldn’t need to worry much about rtirq at 16ms latency.

Missing from the quickscan output is also the limits.conf settings - this one is important

http://wiki.linuxaudio.org/wiki/system_configuration#limitsconfaudioconf

Be careful, there are 2 possible locations - this is distro dependant:

/etc/security/limits.conf or /etc/security/limits.d/audio.conf

Once set (needs a reboot), verify that Renoise is running at a higher priority (should be around 90 if you followed the tutorial to the letter - you can go up to 99).

This is visible in top or htop

Regarding the CPU: as Fernando said, don’t touch if you don’t know what you’re doing.

I wouldn’t recommend to disable hyperthreading (at least yet). Reason: HT works relatively ok on modern Intel Core cpus - that was not always the case.

But you may want to disable turbo boost. Reason: setting your cpu to performance mode might push the thermal enveloppe to its limits.

If the fans go to the roof but the cpu cannot maintain a stable max frequency, disable it. If it’s a desktop with a big cooler that might not be needed - you judge.

If you didn’t run to buy a mac yet, you might get better perf already - good luck :wink:

I fear most important step not fulfilled is - realtime priority privileges of at least 95 aren’t granted, but just 70-80 or so. Just thought this after having seen the link parade circumventing the realtime/audio kernel that was named. I’ve already noticed renoise wants exactly “95” or nothing in some testings. You can test what your user may do with “ulimit -r” in a terminal, and this will apply to every app started from that user, also renoise and jack. This is the limits.conf/audio.conf “rtprio” thing in case you want to fix it to 95 or above.

All other shit is just tuning onwards from 15-20 ms latency to minimum. This could be stuff for another thread surpassing the original documentation with tips and tricks, I dunno.

I’ve already noticed renoise wants exactly “95” or nothing in some testings.

Interesting, never noticed that renoise was so picky.

In htop the renoise thread with the higher prio says 96, but I already found the values are off by 1 compared to what you set in limits.conf or rtirq.conf, not sure why.

Anyway, yes, set it your max rtprio to whatever between 95 and 99 and you should be good.

I have it like that:

@audio - rtprio 99
@audio - memlock unlimited

I’m planning to go back to Linux from OS X (partly, at least).

For me, Toshiba Satellite worked great before (it’s a bit outdated now).

And now i see, that Dell/HP hype is going on…

What experience you guys have with ‘Tuxedo’ books?

I just discovered them, and they are looking good from my.

Did someone have any experience with InfinityBook, for example?