MacBook Pro overheating after upgrading to Big Sur

UPDATE! This is definitely a Big Sur problem. All good after going back to Mojave. I’ve edited this post to make it easy to find.

My MacBook Pro (13-inch, 2017, 2,3 GHz Dual-Core Intel Core i5, 8 GB, MacOS 11.0.1 Big Sur) becomes very hot very quickly running any Renoise project, no matter what the CPU load is. Just after a few minutes the fan is very loud and I start feeling the heat through the keyboard. So I close Renoise and everything goes back to normal right away.
None of it affects audio performance or reflected on the CPU meter (it’s around 3-15% with the latency from 3-20 ms).
Reaper and Reason are running smoothly.

1 Like

which osx do you have installed? i have also 13’ 2017 mbpro (16g ram) but running mojave 10.14.6, and have no issues even with intensive projects. Cheers

I’ve recently updated to Big Sur (11.0.1). Sorry, just noticed I didn’t put this in my post, I’ll fix it. I’m not sure this problem is new, haven’t used Renoise much on this machine before.

https://www.musttechnews.com/stop-macbook-pro-2017-overheating/

one of the tips mentioned there is:
“Do not place it on a soft surface to allow the ventilation at the bottom”

https://www.amazon.com/LapGear-Designer-Desk-phone-holder/dp/B07N9L5FJJ/ref=sr_1_17?dchild=1&keywords=table+cushions&qid=1606930270&sr=8-17

image

Not using the CPU% meter in Renoise, but using an external task process/activity monitor…What is the average CPU% while Renoise is idling and playing a song?

Good tip, thanks, but, as I said, I don’t have this problem with any other software I use

Empty project - around 46%, playing DemoSong - Daed - Bears - 80-90% on activity monitor

I assume you mean no playing (i.e. idling) Renoise.

What happens if you go into the Renoise preferences and under the GUI tab there might be a ‘Limit frame rate to’ option(?) If so, what happens if you click that option on and say set it to a low(er) value, does the idle CPU% drop?

o dear…

thanks for reporting this…
something is maybe wrong with the default or your display or latency settings on Mac
indeed
because on my Windows 2020 CPU (a little faster than yours) the Daed - Bears song
takes 1.2% to max 2% load

Yes, it drops to 25%.
Activity Monitor can show values over 100%, when I play some more demanding projects in Reason, but it doesn’t result in overheating.

I recall that there was a “Monitor Profile Color” issue with Macs - changing to sRGB or something like that might help - there’s a post or two in the forum, I think?

Its then because the GUI is drawn mostly by CPU on macos, at a refresh rate of 60hz or so (depends on audio buffer size in Renoise). mac users usually have a much higher screen resolution, so it has to draw a lot more of pixels. I guess Renoise isn’t really utilizing any GPU support. It uses CoreGraphics, but CoreGraphics still can be drawn on CPU, if macos decides so. Strangely after I updated my GPU (which has a much higher idle frequency) it also seems to lower the CPU usage of the Renoise GUI. I am confused.

The main problem is that the macbook 2017 is poorly cooled. But 46% of one core (remember on macos, if you have 8 cores, the maximum is 800%) permanently usage isn’t so nice either.

image
Screenshot taken on a macos 10.15.7

@taktik can this go into autodetekshun of the Renoise (installer? program?) of Mac versions?

1 Like

Wow, this helped, thanks! Renoise below 40% on Activity Monitor and no overheating playing DemoSong - Daed - Bears

if everything is correctly configured,
Renoise should give around 5 to 10% for the demo song Daed - Bears,
if I may believe the specs of your processor.

Please try to find what preferences for your display you have to adjust.

  • Set color profile to sRGB IEC61966-2.1 or the general RGB color profile
  • Lower the framerate of Renoise in the menu Edit… Preferences…
    (maybe there are more options to check there)

I assume MacOs does come with its correct graphic drivers, but maybe there are also some graphic settings for the refresh rate in MacOs itself, to match with those in Renoise.

3.2_preferences-gui

Maybe setting some other graphics options will lower CPU usage.

sRGB IEC61966-2.1 seems to solve the most obvious problem in my case, but empty idling project at 60 fps is still around 25%

Does this also happen when you have a new song open with nothing in it and do not have play on?

Because Renoise itself for certain should not take much CPU on an empty project.

It should take 2% CPU or so when nothing is happening.

Yes, an empty project not playing is around 25% on Activity Monitor. Renoise is showing “CPU: 01:8%” at the same time.

That Renoise 1.8% should be the expected outcome. It should also somewhat, but not differ much from the overall task viewing %.

I find it strange that it displays 25% here. It can maybe show 3%, but it should not be 25%.

Some graphic (compatibility) options still have to be set perfect.

Also,

  • what happens when you set all the graphic options to as low as possible
    (framerate 20, no tooltips, more compatible GFX options, no effects)
  • what happens when you disable your VSTs in the Preferences… Plugs if that still does not work
  • what happens when you disable all Tools in menu Tools… Tool Browser…

And…

  • Is there another Renoise window open with a song loaded that shows up under the same task, then ignore this