Making Drum Sample Smooth

Iv’e loaded an MP3 sample(a whole song actually) and I want to cut only the drums in the begining of the song.
I actually did manage to do that,but it doesn’t sound smooth.I want the drum roll to loop itself smoothly without the annoying pause

how can I do that?

09xx. HOWEVER if i were you I wouldn;t me loading FULL SONGS lol… Use a program like adobe audition or soundforge to chop it up… You can do it in the sample editor also i believe, that’s just wat I do.


can you be more specific on how exactly I do this 09xx?
I’m pretty new to that shit

It’s probably going to save a lot of time if you just upload an example song with the drum sample in question.

You said “I want the drum roll to loop itself smoothly without the annoying pause”, which isn’t very specific to begin with. I think niNja_pWn3d was just trying to be helpful with the suggestion to use the 09xx sample offset command, but in reality that may not even help you.

Maybe you’re having problems syncing the loop to the song BPM, for example, in which case you might have better luck by exploring the Sync option in the sample properties.

Or you may be having problems with the sample loop itself.

Or it could be any number of other things. So it’s best if you can upload a song, then we can give some better advice based on what you’ve already done. :)

You and your god damn awesome fucking way of saying shit dblue ;) your awesome! lol. I’ll step aside and let shaolin sensi help ya with this one ;)


I tried to read those guides about the samples and the pattern editor but couldn’t manage to do what I wanted.

I’ll try to explain step by step what I did:
Iv’e uploaded a song.then Iv’e used the sample editor to cut only the drums at the beginning.
I go back to the pattern editor and put the sample in row counts forward to line 63 and supouse to loop continuously,BUT there is a small pause(like half second pause or something)and then it loops.

I just want to figure out how to cut off those drums and let it roll smoothly

I hope i explained myself well :\

It sounds like the sample might not be edited/trimmed correctly, so there is some empty space left over. The actual drum loop itself might contain some kind of delay that is causing the pause you’re describing. I really have no way of knowing unless you tell me which song you’re sampling (gimme a link to a YouTube clip or MP3 or anything), or perhaps you can simply upload the sample (as .wav or .mp3, etc) for me to listen to. If you upload the drum sample, then I’ll ‘fix’ it for you.

Or… the drum loop may not be the same BPM as your song, so they’re not actually playing in sync with each other. If this is true, then you either need to set your song to the correct BPM (which will require some trial and error), or you can use the sample sync option which I mentioned before. In the instrument settings you’ll see some sample properties like base note, finetune, etc. You’ll also find the Sync option there.

Turn on Sync, then adjust the value until it syncs up correctly with your song. If the loop contains 4 beats, then you might use a value like 16 or 32. If there are more beats, then you might use a higher value like 64 or 128 or 256, etc. Just experiment until something fits, you’ll get the hang of it pretty quickly.

As I said: if you upload the drum loop, then I will take a look at it myself and fix it for you.

Okay I did was the BPM thing…thank you all for your help!