Master Spectrum shifted downward off screen

Ok this is weird, and took me a few minutes to figure out how to duplicate it, but I now have the steps that should duplicate it every time.

  1. Create a Padsynth instrument.
  2. Set bandwidth to 2 and growth to 0. Leave everything else default.
  3. Generate test note. Should just be a sine wave.
  4. Hit clear and generate test note again.
  5. Draw the “1” back up to recreate the sine wave
  6. Hit generate test note. It should still be a sine wave.

Now in the master spectrum, everything is shifted downward dramatically. If a note is loud enough you can see the peak around -90db, but mostly it’s just completely off the chart. Spectrum VST plugins show it fine (checked just to make sure I wasn’t insane). And it’s just… it’s just a sine wave, I really don’t understand. I even tried resampling it. You can even switch to other instruments, and the other instruments will display fine, but when you switch back to this instrument it will still be off the spectrum screen. In fact you can save the song and reopen it and it will still be this way.

I also duplicated it on my netbook running Linux Mint, so I can make it happen on windows and linux.

Obviously not that bad of a bug, just a minor annoyance under an extremely rare condition. But thought I’d post it anyways, thought it was weird.

what exactly do you mean by shifted downwards offscreen ? the harmonic is not shown at all ?

it’s better that you provide a song with the problem so we can check…

Sure thing, attached. And yes I mean the harmonics don’t show at all.

edit: Here’s a screencap. You can see I’m playing a note, and it’s just a sine wave, and I can hear it, but nothing on the spectrum.

Ohhhh ok. Thanks.

edit: used a stereo expander to make it mono just so I could prove it to my brain.

or just use option in the spectrum:

Channel Mix > L+R separately

so each channel is processed on it’s own and the spectrum is averaged after the transform (phase differences are not visible then).