Midi Channels / Virtual Vst & The Mixer

I have software called Noatikl that is outputing MIDI on 4 channels.

I’ve set up a VST Instrument (Absynth) and 3 virtual VSTs off Absynth.

I pump the MIDI into Renoise and to tracks 1 - 4 using the MIDI In menu to pick up the respective MIDI channel and sent it to the appropriate track – 1 through 4.

I play Noatikl and “edit” the 4 track matrix. Notes appear in each of the four tracks.

However, when I open the mixer, I’m only seeing audio activity on Track 1, the “real” not virtual VST. Nothing I’ve tried so far give me access to hearing the notes in tracks 2 - 4.

One of tow things:

  • There’s something I’m not getting about how this all works
  • There is another configuration step that I’ve missed, e.g. the Output configuration – I’ve tried some things with this with no success.

Thanks for your help.


Plus how you need to set up the routing inside your plugin.
But you mention Absynth and i have a feeling this plugin doesn’t support multiple output busses. If it doesn’t, you don’t see more busses available in the routing tab of the Renoise instrument section for the plugin.
In that case, you unfortunately need a full new instance of the plugin.

Thanks. Yes, Absynth is either stereo or surround. So I tried Reaktor 5 and found 8 output channels. There seems to be a problem with the VST version, but the AU version seems to work.

I guess I’m still confused about what I should be seeing in the tracks I’m routing to. Is it MIDI notes or something else. I’m a bit bleary eyed at the moment but it seemed to me my Reaktor experiment didn’t result in any notes in the other tracks. I will go back and look at the routing situation again. Both within Reaktor and Renoise.

Thanks again.


Is there something in the VST version that you can configure to enable or disable output busses? Some VST don’t advertise their outputs unless they are “checked” or turned on in the VST itself. This usually requires you to unload the plugin after you have made that change (by clearing or deleting the instrument slot) and then reload it into the instrument slot as such change isn’t immediately getting into effect.

The output busses are transmitting audio only. You control a preset through midi by setting the channel in the plugin tab properties of the instrument. In the plugin you configure the channel number that a preset should listen to. Each plugin can do it differently.
In the major cases these actions will suffice regarding Renoise:
Inside plugin:configure each desired preset to listen to which midi channel, configure the plugin to which output bus to route the audio for each preset.
Inside Renoise:Create a new Alias instrument for each extra preset you want to control or have configured in your plugin.
Inside Renoise:Set the specific channel for the specific preset that you want to control for that Alias instance in the plugin properties of the Alias instrument.

Optional but something that Renoise will handle automatically if not configured:
Inside Renoise:Tell Renoise to which track each output bus the audio stream should be bound to.
If it is not manually configured, Renoise will automatically route the audio to the track that the notes are played/recorded in.

Sometimes plugins (like drumatic) play different keyswitched samples and allow setting the output bus on the individual samples. In that case the figure usually relates to an audiochannel only.

The notes themselves always end up in the track where the cursor is because you are always at the scene of the crime where the notes are put, however you are free to tell Renoise to stream the audio through a different track than where you put the notes. Though i doubt anybody does that because that works really confusing visually.