Midi Clock Renoise 2.1.0 On Ubuntu Studio 8.04 Xboard And Midisport

Hi, I have two computers, one a toshiba satellite, the other an hp D330. i have the satellite connected through USB to an emu xboard 49, with the xboard’s midi option set to thru, and the midi out of the xboard going to port B of a midisport which is inturn connected via USB to the hpD330.

I’m running the lateset and greatest renoise 2.1.0 on ubuntu studio (ubuntu 8.04), both 32 bit.

I set Renoise’s prefs on the satellite to clock master “xboard midi1”, tick “send clock” and “send start/stop”, slave is set to “none”. and no mappings are set for the ins or outs on the satellite…

On the HP, simply have the MIDI slave set to port B of the midisport. no Master port selected and no ins or outs. When I close the prefs, I see a red pulse next to “sync” on the satellite, with a synchronized green pulse under “sync” on the slaved HP. looks nice. then when i hit play on the master satellite, the master plays, but the slave does not. If I go to the slave hp, and play into the first pattern, then stop, and hit play on the master satellite, at least the slave jumps to the beginning… but hitting play on the master does not also send either send or stop to the slave . . .

am I missing something? Is this something that worked on earlier renoise versions or is this across the board a bug? (so i don’t go mad trying to make this work!)

I’ve reversed the signals, tried w/ the hp as the master and the satellite as the slave, set the prefs accordingly and also have tried the other ports on the midisport (only 2 total on the midisport) to no avail.

any help would be appreciated!!


One of both needs to have this little thingy toggled:

Also check if you have enabled all required options here correctly:

[quote=“vV, post:2, topic:25985”]
One of both needs to have this little thingy toggled:

Ah. by default they both were enabled… the help says “act as midi slave, when enabled” so when i turned this off on the midi master and opened my eyes after hitting play… alas, the slave… was still not playing. hmm. are there any other toggly things that need to be toggled for to be able to sync playback and stop to another machine running renoise??

additionally i’m quite certain i have my prefs set correctly, as i’ve said the slave will go back to the start when i hit play on the master, and i’m getting a sync green (in) pulse on the slave “led” and a sync red (out) pulse on the master… this would seem to indicate there is communication… just not sure why toggling start/stop wouldn’t do what it’s supposed to do?! does this only work through virtual ports with other programs through something like rewire or jack??

Perhaps some Jack Transport option is causing problems in the MIDI Slave area, you might need to turn off jack transport in the preferences, forgot about that option…

Jack transport does work, but has no great sync capabilities yet either.
I have no idea if jack transport works the same between two computer though, never tested that.