Midi input routing: mono option in instrument interferes with incoming midi data

First of all ,in this example renoise is NOT used for sequencing and recording , only as a vst host and pc keyboard as midi controller for real time recording in the cirklon .
Here goes
I control a renoise instrument from the cirklon , the instrument is set to receive on midi channel 4 over cirklonusb , midi comes from a cirklon track set to usb , channel 4 .
Let’s assume this sequence s playing c3,d3 notes in the cirklon .
Works great , the instrument in renoise is set to mono ( for nice glide effects )
Now , I want to record another sequence in the cirklon , and this instrument will be receiving midi on channel 2 ( also from cirklon usb )
For this I create a dummy instrument in renoise which sole purpose is to use the pc keyboard for real time recording into the cirklon , the output of this dummy instrument is set to 'cirklon usb ', so the data will be recorded into the cirklon and it will then trigger the correct vst .( some necessary steps have to be made in the cirklon to prevent midi feedback but I got this all set correctly )
The big flaw with renoise is the following , when recording from the keyboard into the cirklon while the other instrument is being sequenced ( the one set to mono and playing c3,d3 ) it will cut off the notes c3,d3, of the new recorded instrument .
When the instruemnt is not set to mono , it wont cut off notes .
How can this even happen since they are both receiving on a different midi channel ?
Turning of the instrument mono setting solves the issue
When you look at the midi monitor wou will always see incoming midi notes , even when there is no midi input channel selected , I think that’s where the problem lies and or the MONO button in general

Edit it doesn’t matter which notes are played , an instrument set to MONO will automaticaly cut off new recorded notes