Midi input's note-off not recording to renoise

Hey, I can’t seem to backtrack how to get my note-off to record. It was recording the notes off, but I was messing with the midi’s record & play filter and it stopped functioning. Has anyone else encountered this problem? pattern window Midi monitor

*I also tried it with my nanokey studio and got the same results.
Windows 10

Select your MIDI Device “MC-707” in “In device A”.

The left MIDI setup panel is unique to each instrument.
In the preferences panel, the filters work with In device A, In device B, In device C, In device D.

1 Like

Thanks for the reply!

I added the midi controller and started to fiddle around with it. I got the same results, but over time it did work again for a moment, but as soon I started to change the midi filter settings again, it broke.

I think there is a bug in the polyphonic aftertouch settings. I had the same problem at the very beginning but fixed it by unchecking that box.

is this a possible bug?

I do not think so. Deactivate the MIDI input and output panels on your left panel. Activate it only from the MIDI preferences panel.

Hey Raul, I might be missing something here. I tried it on my MacBook, and it’s not working either.

here are my current settings:
midi in device

Are you using long sounds or loops?

If the sound is not long enough, renoise will not write a note-off. Based on the MIDI data, Renoise is correctly receiving the order to turn off the note.

As it stands now, the pattern editor should record note-offs when appropriate.

i found the bug that causes my issue. if I open a new project, the bug will be there. Whereas, if I open up a demo song and record my midi on a current track or on a new track that I have made, my note-off will be applied after the release of my note input.

this also is a fix for renoise on mac.

having the same issue in 3.3.1.

notes entered while recording during playback via midi or computer keyboard will be recorded into the pattern as expected, however their corresponing note-offs will not be recorded as pattern data.

  • the midi monitor displays that note offs are being received and logged by renoise
  • the midi record&play filters are configured to record note off information in the preferences

i eventually get it to work in some of my projects and it seems to reliably work when i load a demosong (as described by quangstuh before), but to me this does not really “fix” the actual problem, especially with WIP .xrns.

as far as i can tell, there’s something wonky going on under the hood.

to reproduce:

  • start a new song (no template)
  • hit play & rec with pattern follow enabled
  • enter notes with midi or computer keyboard
    ==> note-offs are not being recorded

any (more recent) thoughts?

For the Note-OFF to be written in the pattern editor, it is necessary that the selected instrument is not empty (that it has samples or a VSTi …). It is necessary that “sound exists”.

Did you configure any instrument?

to avoid a midi loop i dont have an instrument selected as i am recording midi for my hw synth.
using local off is also not an option in my usecase, but at least i now know why things happen like they do. thanks Raul.