Midi Instrument Note Polyphony

Just switching between 2.7.2 and 2.8 beta 6 I notice right away that in 2.8 I’m not getting polyphony when playing the midi controller assigned as Renoise’s MIDI in, triggering, say port 1 of my MIDI interface going out to a kurzweil stage piano. When I switch to 2.7.2 I get polyphony with out having to change anything (unless I set it up long ago) I don’t see any obvious setting in the prefs.

Maybe I’m missing something or maybe something isn’t working right?

It seems like the later as when I load an xrni or a sample i get polyphony right away, playing the same midi controller as the input device, just not with MIDI…

same overall behavior if i’m triggering the stage piano via QWERTY or MIDI.

It would be kind of cool if there was a feature similar to fast tracker’s key jazz - your level of MIDI or QWERTY polyphony for any type of instrument (MIDI, sample, etc) would be based on how many tracks you have enabled to record that instrument, say in the scope view. If you didn’t have it enabled you basically wouldn’t have polyphony. It would kill two birds with one stone as it assigns where your recorded notes go.


follow up:

ok… so “chord mode” is what I want.

[s]Interesting though, as I had tried that before posting this but when triggering notes I was using the QWERTY.
Enabling chord mode doesn’t seem to impact qwerty polyphony for Ext MIDI instruments… It is the answer for getting polyphony (in other words being able to play chords) from the MIDI keyboard assigned to the MIDI in but seems it’s just not working with the qwerty as it does in 2.7.2 after switching over to compare.

i’m running the mac X64 rev6 beta[/s]

uhh… ok… just rebooted and zapped PRAM… logged back in, opened renoise 2.8 beta 6 chord mode works just fine with the qwerty. go figure.