Midi Keyboard Volume

I’m quite new to MIDI keyboards so can anybody tell me please why the volume seems to be lower when i enter notes via MIDI keyboard… I know that the keys are velocity sensitive and volume depends on the speed i enter them, but for some reason the maximum volume is around 30 in renoise equivalent…

i have M-Audio keystation 61es that i bought today :)

If you want a second opinion on the velocity there is a useful utility
that displays all midi information:

Midi Ox

But please not that “30” is hexadecimal and 40 is maximum in the velocity
colum, (corresponding to the maximum “128” in normal midi).

3A is the highest velocity I managed to get in renoise but I love my keyboard
to much to really spank it.

A little tip:
MidiOX can be configured to translate velocity values, and feed to a MIDI-in port, so as to apply a velocity-“bias” to all keys pressed.

yeah, i know that 40 is the maxinum…

but thanks for the tip… i’ll check that utility out!! :)

My current MIDI kb is actually an old Casio synth (CZ-1000 to be precise) with no velocity sensitivity and all my recorded notes appear at 50% volume or 20h. Actually it’s good because it automatically reduces clipping while working on a song but is there a way to change the default volume for plain velocity insensitive keyboards? Also, I would like to match the volumes of notes entered with the MIDI kb and the typing kb :slight_smile:

Check to see if it’s your casio that is transmitting the velocity at 50%. I’m pretty sure that midi requires velocity to be sent with the note-on message, so the casio would be preset to send at halfway. Strange, really, but I can see that as the only logical explanation. You could try unchecking the “Record velocities” option in the configs menu

There doesn’t seem to be any velocity settings in the Cosmosynthesizer but disabling velocity recording in Renoise indeed does “the trick”. Now both kbs’ volumes match. Thanks.

it’s a shame that renoise doesn’t scale the velocity but simply cuts off everything above 40h. trying to play a synth with a velocity controlled filter in renoise is totally shit.

But it does scale…


…doesn’t it?

ouch just tried it again, it does seem to in the version i have now…
hm when i think about it, i think the last time i used my keyboard with renoise has been in the pre 1.5 days :huh: