Mint Linux + Jackd + Renoise?

I installed the recent demo and when I type “renoise”(without jackd started) at the terminal it only says “Segmentation fault”.
If I start jackd and try to connect it says “cannot use real-time scheduling (FIFO at priority 10) [for thread -1217005888, from thread -1217005888] (1: Operation not permitted)
cannot create engine”.

Ofc I modified limits.conf, added the lines “myname -rtprio 99” and “myname -nice -10”.
Here I have another question:
Is it 100% “-nice -10”(2 times normal minus)? In the FAQ the “-”(minus) before 10 is a bit longer than a ususal “-”. :ph34r:

Some people have more lately said the Nice setting was a red herring but personally I couldn’t tell you even exactly what it does so have just followed the instruction. Those numbers actually come from the Jack documentation (you are recommended to set them when trying to run it if they are not present) and think it was one of the Jack developers who has since said it shouldn’t be needed. But yeah, that’s right.

You have put your username/group and not actually myname haven’t you? More usually it is recommended to change those settings for the Audio group and then add yourself to that group. Or there is a group (seen the id number posted) which is anybody who uses a local logon, which some people recommend.

Where/How can I create this group “Audio”?

Audio group exists as standard. Well at least the do on Ubuntu Studio and think the other Ubuntu packages. Not tried any others.

To view user and groups go System > Amdinistration > Users & Groups. Click the little key at the bottom, enter you password. Click on Manage Groups, find audio, double click to edit and put a tick against your username to add you to that group.

Or type “sudo adduser username audio” should add you to the audio group. Change [username[/i] for your login name obviously.

It still doesn’t work:

21:17:56.688 Patchbay deactivated.  
21:17:56.688 Statistics reset.  
21:17:56.769 ALSA connection graph change.  
21:17:56.959 ALSA connection change.  
21:17:57.407 Startup script...  
21:17:57.408 artsshell -q terminate  
sh: artsshell: not found  
21:17:57.808 Startup script terminated with exit status=32512.  
21:17:57.808 JACK is starting...  
21:17:57.808 /usr/bin/jackd -R -t5000 -dalsa -dhw:0 -r44100 -p1024 -n3  
21:17:57.810 JACK was started with PID=2011.  
no message buffer overruns  
jackd 0.116.1  
Copyright 2001-2005 Paul Davis and others.  
jackd comes with ABSOLUTELY NO WARRANTY  
This is free software, and you are welcome to redistribute it  
under certain conditions; see the file COPYING for details  
JACK compiled with System V SHM support.  
cannot use real-time scheduling (FIFO at priority 10) [for thread -1216108864, from thread -1216108864] (1: Operation not permitted)  
cannot create engine  
21:17:58.068 JACK was stopped successfully.  
21:17:58.069 Post-shutdown script...  
21:17:58.069 killall jackd  
jackd: no process found  
21:17:58.474 Post-shutdown script terminated with exit status=256.  
21:17:59.964 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.  

And I still can’t start Renoise, even without jackd I can’t:

desktop ~ $ renoise  
Segmentation fault  

WTF is this?

Have you followed teh instructions to install it systemwide?

If not try clicking on the file with the Renoise logo as an icon wherever you downloaded it and see if that works. (Edit: actually try this no matter what.)

Renoise should fully load with neither ALSA not Jack running (as I have experienced during testing when I’ve had them both tied up or not running.)

Ok, dopple-clicking on the renoise icon starts the program, but it still says that a realtime priority thread cant be created for alsa. This is odd cause i am part of the audio group by default and i added the @audio lines in the limits.conf!
I installed renoise via “sudo sh” which shiuld nstall it system wide, doesnt it?!


I’m using renoise on Mint 8 with Jack, it works fine. What version of the kernel are you using? Do you have a real time kernel installed?

Yep sounds like no RT kernel installed. I found the ubuntu studio preparation guide very useful for setting up any Linux distro for audio, just follow the way your distro works… i.e. if you don’t have apt then use whatever your distro uses.

This is taken from the guide - so props to the ubuntu team!:

Real-Time Support
After you’ve got the kernel you still need to set up real-time access for your applications.

All you have to do for this is give your audio group permissions to access the rtprio, nice, and memlock limits. To do this, you just need to run these commands, which will add some lines to the file /etc/security/limits.conf:

sudo su -c ‘echo @audio - rtprio 99 >> /etc/security/limits.conf’
sudo su -c ‘echo @audio - nice -10 >> /etc/security/limits.conf’
sudo su -c ‘echo @audio - memlock unlimited >> /etc/security/limits.conf’

These value are suggested by The memlock line determines how much of your memory can be locked by audio processes. Some recommend setting this as half of your total memory (RAM, in KB). See Florian Paul Schmidt’s page.

If you use a Firewire sound card, you already done the step described here: in Hardy and Karmic beta, this group is already created at installation. You just have to do:

sudo adduser audio

full guide here

hope this helps you mate

Linux is installed. I thought I dont need to install a realtime kernel. Since adding these 3 lines you mentioned to limits.conf works fine for Ubuntu(9.04)
No wi will try to install the realtime kernel. Is there something special i have to consider? Special rt kernel version that is buggy or something like that? I think i read about this some time ago.


I tried/installed linux-image-2.6.31-9-rt
And i get the same errors. :rolleyes:


Ok, now i am completely confused! I am back to 2.6.31-14 and i just started renoise to use it with alsa and without realtime. Doubleclicking on the renoise icon opened it up without any notification about “rt is fucked blabla”.
Preferences show me that i am using jack. :huh: I thought I didnt even started jack this session.
Normal way i used to start jack is to load jack_control and click “start”. Which worked fine in ubuntu9.04, but doesnt in mintlinux 8. So before in realtim kernel 2.6.31-9-rt I experimented a bit with the terminal and did “jack -R lollig -v -t 5000 -m -d alsa”.
Does this command “installed” a “hidden” jackserver named lollig in the backround? how do i deactivate this server? and why is it working and jack_control is not?
If i start jack_control after renoise it displays a running server.

Have you tried “killall jack” as that should kill any processes called jack which are running.

Or “ps -ef | grep jack” should highlight any processing running with jack in their name. Ignore teh one that ends “grep --color=auto jack” as that is the process you just ran to highlight jack itself.

I just recognized that when I start Renoise, jackd is started automatically. This is the normal way?

When you installed the RT kernel, did you use startup manager to change the boot process to use the RT kernel? Installing from synaptic alone won’t necessarily make the new kernel boot.

are you trying to run a renoise 32bit on a 64bit system, by any chance ? It would explain the segmentation fault.

I am not sure how good the rt kernels for mint are, every distro is different. But you def want a rt kernel for audio work in linux. Do you have qjackctl installed? that is what you want to use to control jack.

When setting up any distro these are the steps I take.

Install the distro
install rt kernel
Install ATI or Nvidia drivers if needed
create audio group
set the limits.conf
enable alsa midi-seq
install jack, qjackctl, ardour, sweep, ams
install renoise
build and tweek system

when i want to work with audio
start qjackctl (you need to play around with the settings - make sure rt is checked)
then renoise

I am running i686 which supposed to be 32bit, isnt it?!

Ofc I tweaked the bootupmanager to load the new kernel on startup, checked it twice with systemprofiler, to be sure I am running the rt kernel. ^_^
qjackctl is installed along with jackd. Audio group already exists. And definetly works, since I now can use rt priority with jack+renoise without having a rt kernel installed.
The strange thing about it is, I only have to start Renoise and “Renoise makes jack start automatically in the backround(without GUI)”!
I never had this “issue”, its working normal as i am used to. But I like to start jack, make it work and start renoise after. :wacko:

btw, i am not using any hardware I think i dont really need ultra low latencys due to realtime kernel, ~30ms are fine for me.


The mystery deepens! But I guess as long as its working fine for you, that’s great. What version of Jack are you running? You should be able to type jackd --version without getting an error message. I’m using 0.118 wihtout any problems. I have written a blog about setting up linux mint 8 to use jack with a realtime kernel, it’s at

“jackd version 0.116.1 tmpdir /dev/shm protocol 24” is installed via apt-get.
I will check your blog out. The problem is, i cannot change the settings of jack when its started in the backround by renoise.

You can start jack before Renoise does by using jackctl, then you can change lots of stuff in Jack.

I did this ofc. And I said, when I press “Start”, I end up with an error message like this:

I just reinstalled Mint Linux 8 Helena from the scratch with this roadmap


Nothing changed. Still this error.