Mouse Weirdness

Sorry if this has been covered but I’ve had a look and didn’t find anything in the forum.

When I click and hold the left mouse button the pointer disappears. Then if I try to move up or down on a a slider, I seem to have lost focus and the movements are erratic and generally don’t work. :blink:
2.1 and the 2.5 beta.

Can anyone help?


Thanks I’ll triple check but I’m pretty sure I’ve tried both ways :slight_smile: I do think I have a mouse in renoise problem. It’s fine on my laptop but not desktop. It’s just vista and an ms optical wired mouse. It happens on all sliders including vsti.

I’ve checked again and might have to move this to a bug. On my desktop vista PC, whenever I click on a slider in renoise, the mouse jumps up and left (aprox an inch or two on my particular desktop) making it impossible to change slider positions.

The slider moves to the far left (in the case of a horizontal slider anyway) and stays there regardless what I do (presumably because the mouse pointer has for some reason gone up left as explained.

It doesn’t happen in the pattern editor or any other applications.

Any help appreciated.


Do you’ve got any desktop extensions (tools to pimp the windows GUI, behavior) or mouse tools like Synergy installed?

Is the windows taskbar on the bottom and does this work when running Renoise fullscreen?

And you’re not running your OS via Remote Desktop or something like this?

Hey taktik,

I’ve not got any desktop extensions that I can think of no.

I’ve tried it both in windowed and fullscreen, same thing. I’ve also tried going down to 1024x768 res incase it was my dell widescreen monitor 1680x1050 res doing it. Same thing.

I’m running locally not remote.

I believe I’m just using the windows default driver for the bog standard microsoft optical mouse.

It’s interesting I think that I can drag to select areas in pattern editor fine.


I’ve not noticed this option before but I’ll give it a go when I get home.

Vista mouse aero scheme buggy…-accurate/2610/

If that doesn’t work I’ll try a different mouse.

I’ve tried the above vista aero change and also a different mouse but it still doesn’t work :frowning:

Update… it works :slight_smile: But I have to turn vista aero off completely. Not a big deal but might be for some.

Maybe it’s enough already, if you open the Renoise shortcut properties and go to the compatibility settings and disable visual styles there?