My 30 Gigs Of Samples Vanished?!?!?

okie im faced with a dilemma, 4-6 months ago i moved my entire 30+ or so gigs of to an external drive, this drive was a drive i was using previously as my primary hd of my 2nd to last install of windows xp.

-a little background on this.

the drive was primary, it had 3 partitions on it:  
C: for windows  
D: for audio programs & sample bin  
E: for data dump  
some weird problem occured and i couldnt figure out what to do, it wouldnt let me boot any windows dvds or cds with my cd or dvd drive, but i could run knoppix an look at everything, and even transfer stuff but i didnt have anywhere to put all the data. so being lazy i just let it sit, it sat for about 5 months, i didnt need the samples because i had all my coveted samples already in RNS modules. so finally i got a 300gig and i made it the primary drive.   
i opted to just leave the samples on the other drive, that i put in an external enclosure.  
so i started bringing my mydocuments and various other things over to the new install so i could turn the drive into 1 partition again, that isnt exactly finished yet becuase of the amount of shit ive collected. i did however decide to do away with the windows directory, but then for the longest time i would get errrors from recycle bin saying you cant delete GAC because directory is not empty, and then i noticed something strange.  

at the time i was using a new folder for a bunch of new samples i recorded an it just became my samples folder i was working in for quite a bit.
one day i went looking for it an it was gone. i thought oh F***!! i deleted it while i was real stoned cleaning up my archive.
an then i noticed all my folders incased in brackets are gone!!
an so on…
i was doing that because having the brackets makes them stay at the top
i opened up wavelab5 becuase i remembered that i was using it the night before, an to my surprise the data and folder was chillin like nothing happened. so then i went to the explorerer address bar an typed yada[new] an it magically appeared.

well i didnt do what i was supposed to do an copy everything off the drive.
an then recentally the main folder (Sound) and all its contents VANISHED!?!?
so i made a new folder called (Sound) thinking it would register with the tables an it would see everything, well it didnt. an now i cant figure out how to get anything out.
until now i have been putting it off for a couple weeks thinking that the answer will display itself, either by me having an epiphany, or someone coming along that has already had the same problem.

im pretty sure that the partition table must be messed up but i havent done anything about it thinking that theres a good possibility that whatever way i choose to fix it with, could also obliterate and scramble the data. also if i just tried to undelete it i would probably not be able to save any of the names and i would have a huge amount of un named data to sift through.

so im very hesitant to do anything unless i feel sure the route i take will be a success.

anyone have any other options?

try booting to knoppix and see if you can see the files…

and btw, what do you see as drives free space? is it corresponds to files being deleted?

you can also try some data recovery software to recover deleted files…

I don’t know what to suggest, but if you can’t recover any of your shit, I have a good 40 gigs or more of samples (plethora of different drum, acapelas, synths, loops, rexed and plain breaks, sound effects- everything). Just let me know and I’m sure we can figure out a way to get them to you. Good luck, that’s some sore shit. :(

louis, is there a chance you have some 90’s eurodance acapellas in your collection? i think not, but what the hell, i ask anyway :)

Na- a bunch of dance hal and hip hip…

i had not thought to look to see if i could still seem them in knoppix, that gave me an idea to just mount the hd over firewire with my ibook an yep they are still there, so far only “ls” can see them tho(ls -R), but i cant cd into ./(Sounds) so it can ‘See’ them, but not access. the finder cant either, kinda wondering if i should just try an dd them to somewhere else, only i dont know what the problem is yet so i could end up with the same thing in the dd image.

i have a theory of what it is but i dont yet know what it means.

somethingn about tokens?

( <–that apparentally is a token :D

since i enclosed my folders in them

( <–that make problem


i could paste my buffer of my 30 gig folder contents, which is stupid yes. because its. alot.

its hard to tell from the distance, whats going on… so if that data is really important to you i would suggest to ask some IT specialist or some firm who offer data restoring services… before you completly mess up your stuff to the point of no return :)

Sorry if this sounds silly or obvious, but have you tried escaping the parenthesis when doing cd?

ie: cd (Sounds)

or putting quotes around it

ie: cd “(Sounds)”

If you can get into the directory this way, then perhaps you can also rename them this way and make them visible again?

I’m by no means an expert on the mysteries of file systems, but it could be worth a shot.

actually Dblue, thankyou! the way you looked at it, made me realize how simple it might be, so i performed a chkdisk on win32 an it fixed the whole thing!

i did however fix (Sound) to Sound
i never knew about this whole parethesis thing tho, i still am somewhat confused on whether or not me using ()'s for folder names created the problem
in the first place, i never use console or prompt to mess with audio so i never ran into it

my 30 gigs are back! wooo hooo!

man, thank you all for your generousity and help toward this,
i dont know if it was the wisest thing for me to use chkdisk, but am i glad it worked!