Native Instruments VSTs unresponsive behaviour

Hi everyone!
As previously said by few of the members,NI plugins are not really responsive, and I have faced this (like trying to swim in the pool of honey), but yesterday I have tried to manipulate with the sound in Massive X and not been capable to move an axon of the line (see attachment)

Screenshot 2020-11-15 at 11.20.49

I’ve tried to switch colour profile (workaround for UI lag) shrink the window…
Doesn’t help anything

This may have to do with the
UI Scaling Options

  • Select the plugin.
  • Open the Plugin tab
  • Click the [ ? ] button on the left top.

You can there disable the UI Scaling, or set the other available options per plugin, such as static buffering, multi-processor usage and auto-suspend.

@taktik taquetiekque can the [ ? ] button be better named [ Plugin Settings ] in the Plugin tab

If I click “?” button This small popup window doesn’t have any UI scaling options.
See the screenshot.
Screenshot 2020-11-26 at 23.32.33

Are you using and older version of Renoise?
The latest version of Renoise is 3.2.4…

No, it’s 3.2.4 (see screenshot attached)
Right hand side upper windows “About”, lower window “Plugin ?” button
Screenshot 2020-11-27 at 14.28.32

I think you’ll find that macosx or linux Renoise doesn’t have the ‘auto scale external editor’ option in that dialog.

1 Like

I believe Massive X in particular can be helped by changing its theme to Flat.

1 Like

I did not know that. Thanks for clearing that out.

@Garf thanks!