New Linux PC - best option?

If it is possible, I would rather be interested in what kind of latency will remain on the selected components. You can have a great PC configuration, but the latency for realtime applications is terrible. Linux vs Win is also different. In win11 I have a lot of services turned off so that the audio is clean, in linux it’s ok. If possible, run the PC through the latency monitor.

Edit: Ah now I noticed it’s for Linux :wink:

1 Like

Yeah on Linux you have to know some things to make a good tuning.

In my experience some machines are great right away. The usual kernels are already good, and sometimes you can get much better performance even with lowlatency/realtime kernels. If you know how, you can just disable anything if it impedes your realtime performance. I know that with a good stock kernel and good machine, you can sometimes already have already sub 10ms latency, and with realtime and tweaked optimal interrupts, pci pro audio cards etc. you can tune some machines to like sub 2ms without xruns as long as the software used allows such insane latency. Then you can even use the machine as realtime effects processor, or for guitar amp modelling without any perceivable lag…!

But there can be individual drawbacks, like graphics card/driver problems, hardware NMI/Interrupt issues, or stuff like that…and then you get xruns when going very low with the latency. This can be real mayhem to debug. I even went as far as doing ftrace through the kernel to see what is the source of what jams up the audio threads/interrups. Some hard drive/file system features are vital to disable on some machines. Or a graphics driver makes problems, and needs to be configured or replaced with an alternative. You’ll see when you try to tune the machine. I’d for example expect a workstation device to be more compliant for realtime work than a consumer or office product, but sometimes you get lucky and the machine works just fine.

Renoise I didn’t manage to drive glitch-free in a stable way I think sub 5-8ms (with jack) depending on machine yet, even when other progs would do it. I guess this is a renoise issue.

Vital tunings:

  • turn off unnecessary devices and programs, use proper sound card able for low latency
  • realtime priorities set, using proper realtime audio stack (i.e. jack…)
  • Disable or tweak CPU frequency scaling, i.e. setting to “performance” mode or disable stepping, is akin to setting performance mode in windows
  • You may have to disable some file system options like journaling
  • to get even further, you have to tweak interrupt priorities i.e. via the rtirq init script, and using a lowlatency/realtime kernel would be either prerequisite or even necessary (can’r remember RN) - you need to know the hardware and how to priorize your sound card
  • if there are still too many failures/xruns, you have to debug it as a kernel/hardware/driver issue, good luck… :kissing_heart:
1 Like