New Tool (2.7, 2.8): Edit Step Zeroedit Tweak


Howdy. Another solution for a workflow-issue regarding EditStep.
I’ve got the EditStep movement keys bound in ‘inverse’. Meaning I’ve bound the plain, no modifiers up&down keys to moving with edit step, and the ones with modifiers into moving with step 1.
Yep. That’s the kind of guy I am. And that’s fine, as long as you don’t use zero edit step. When this happens, the up&down don’t work no more, and you’d have to specifically use the modifier keys. Well I won’t have it. Enter some lua-trickery.

Updated. Fixed the move function.
2722 com.kmaki.EditstepZeroeditTweak_Rns270_V1.1.xrnx

This will let me edit stuff with zero, and while editstep=zero, still move with step one.

I’d like to thank joule for that move-snippet! Thank you, joule. :)

can you make a modification to this so that it steps to the next notecolumn, if edit_step=0

When you move down with edit step zero, the cursor moves right?

yep, exactly. does it do that? :)

Nope. ^_^

Anyone that would want this feature, should start by writing a function for moving the cursor right (and expanding the columns?) (and left? for up?). Then that someone would have to replace the bit on main.lua where it says:

if e_step == 0 then  
 --move one even if edit step IS 0)  
 move_cursor(1 * dir)   

with something like this for example:

if e_step == 0 then  
 if dir = 1 then  
 --GO EAST!!!  
 --GO WEST!!!  

Actually, there might be a need for an all-around snippet for moving the cursor left and right through the lua-API. As this is sometimes not so simple either.

Hi. I haven’t used it yet but this error message just popped up:

I’m on Renoise 2.8 beta 2 on OSX Snow Leopard.

I’ll try and replicate in order to fix this. Would you happen to remember if you were doing something special when this appeared?

not really. just playing with slices, recording in realtime, and triggering patterns

Hey, I just noticed from your error message that this is actually the PLAYBACK tweak you bugged with. Not the zeroedit tweak. :D

And I’ve encountered the same bug just the other night, and made a slight modification to my local script that seems to eliminate the bug. Didn’t have time to upload it yet, but I’ll upload it tonight, when I’m at home. I faintly recall that this seemed to happen when stopping playback at the very end of the pattern. My script tries to set the edit position on a line that is outside the pattern bounds. Sorry about the inconvenience…

Should this still be working in 3.1? Will there be an update? I prefer to disable all wrapping :]

Actually, maybe it is performing the same. I thought I had the ability at some point to disallow wrapping and ramming when entering note and effect data in regards to edit-step length.