New Tool (2.8) Duplex: Grid Pie


(danoise) #141

Yes, happy owner of a monome 128 :slight_smile:

Ah, nailed it. If you open the control-map, you’ll see that the navigator group buttons have incorrect horizontal indices.

Where it says ```

It should go like this   
(repeat for every buttons with 15 as horizontal position)  
  
PS: sorry P.E. Viau for not basing all the m64 maps on your adaptations ![](https://files.renoise.com/forum/emoticons/default/blush.gif)

(dby) #142

Great! That fixed the Navigator.

Congrats! :)


(Skia) #143

I can’t seem to get my monome 40h to be detected from Duplex. I’m using serialOSC.

What do I need to do?


(danoise) #144

@Skia: I’ve sent you a PM


(dby) #145

Got an error when I tried cloning two or more patterns in the pattern sequencer:

'C:\Users\DBY\AppData\Roaming\Renoise\V2.8.0\Scripts\Tools\com.renoise.Duplex.xrnx\main.lua' failed in one of its notifiers.  
The notifier will be disabled to prevent further errors.  
  
Please contact the author (danoise [bjorn.nesby@googlemail.com]) for assistance...  
  
[string "-- create or convert a table to an object t..."]:66: bad argument #1 to 'table.copy' (table expected, got 'nil')  
stack traceback:  
 [C]: in function 'assert'  
 [string "-- create or convert a table to an object t..."]:66: in function 'rcopy'  
 .\Duplex/Applications/GridPie.lua:3613: in function <.><br>```

<br>
<br>
<br>
<br>
Also, a small annoyance... When clearing/cutting a muted block in the matrix, the empty slot becomes unmuted (and a led on my monome lights up when it's updated by changing pages), and I'm forced to mute it manually. Not a big deal, but slowing down work flow a bit.<br>
<br>
<br>
...After doing some more testing I found more related things:<br>
<br>
When clearing or cutting an active slot it seems to break the edit-synchronization of the related slot in the grid pie pattern. After that, any block that I copy into the active slot isn't copied/updated to the grid pie pattern until I switch the slot off and back on.<br>
<br>
Also, when dragging a muted block, that slot becomes unmuted and lights up a led. And if I drag that block to an active slot, it will play, but show as muted. Which also reflects on the monome.</.>

(danoise) #146

About to fire up Renoise and see if I can recreate the things you mention.


(danoise) #147

It seems the bug has been squashed.
You can try out the new GridPie from the SVN if you like, here is the link

About the annoyance - yeah, I can see what you mean, but as you say it’s hardly a big deal right now.
I would be implementing something into GridPie, only to fight the default behaviour in Renoise (which is to un-mute cleared slots).

But I do have a list of stuff I’d like to fix, features I’d like to add - at the top of the list:
making the row of GRID PIE buttons assignable as a separate mapping (that would make it optional too)

Thanks, I will take a closer look


(dby) #148

Great! Works fine cloning multiple patterns now.


(dby) #149

Oh, is that why it says “press the GP slot” in the manual, when direct copying using Multi-touch gestures? …also for saving recombined tracks when recording actions… I just thought it might be available on a different controller but not my monome40h.

Playing with Recording Actions now. This is fantastic! It’s the “pattern recorder” I’ve been missing from MLR and MolarVST. One thought… I tried setting length of the GridPie pattern to twice the length of the other patterns, to allow for a longer loop. But it reverts back. It might be nice if you could set the length of the GridPie pattern and it stays, perhaps as an option? I can imagine using say 16 step patterns and a 64, or perhaps 128 step GridPie pattern.

Oh I noticed the Navigator stopped working when I installed the latest Duplex version. Had to edit manually again.


(danoise) #150

This mode is quite demanding of the CPU, I have some optimizations planned. But yes, Grid Pie can record your live sessions :slight_smile:

I’ve been planning to improve this aspect of the tool so it automatically will create “sections” in the pattern sequence, making it
easier to spot where and when you recorded something. E.g. “GP Session 22:31”

Well, Grid Pie is “stupid” in the sense that it always combines the lengths of all slots. This is really fundamental to how the tool works.
But: if you would like to have a pattern of 128 lines all you’d need to do is to include a pattern with this length - it could even be a dummy pattern with no content.

Thanks man, this will definitely be fixed in the next release :slight_smile:


(dby) #151

Ah, I was thinking about whether I could use some kind of dummy… Great! That solution works just fine.

I tried a 512 step GP pattern. There are some heavy lag in the Renoise GUI and the monome LED updating, but it still works quite well. I don’t think I can hear any problems with the sound or tempo. :)


(dby) #152

Everything in beta 26 working fine so far. Good job! :)

I’ve been trying to wrap my head around editing the config/controlmap. I finally managed to add “edit mode” to the bottom left to quickly being able activate Recording Actions. Nice indeed :)
I also added Rotate: “Nudge track up” and “Nudge track down” to the two unused buttons in between. Seem to work like a charm. :yeah:


(dby) #153

I got an error while doing some stress testing. I had noticed some new timing issues, and the only big change was installing Illustrator, so I tried uninstalling it. Seems GridPie was more responsive and less timing glitches after the uninstall. Then I got this error:

'C:\Users\DBY\AppData\Roaming\Renoise\V2.8.0\Scripts\Tools\com.renoise.Duplex.xrnx\main.lua' failed in one of its notifiers.  
The notifier will be disabled to prevent further errors.  
  
Please contact the author (danoise [bjorn.nesby@googlemail.com]) for assistance...  
  
.\Duplex/Applications/GridPie.lua:2528: attempt to index field '?' (a nil value)  
stack traceback:  
 .\Duplex/Applications/GridPie.lua:2528: in function <.><br>
  (tail call): ?<br>
  (tail call): ?<br>
  .\Duplex/MessageStream.lua:89: in function 'on_idle'<br>
  .\Duplex/Browser.lua:2030: in function 'on_idle'<br>
  .\Duplex/Browser.lua:183: in function 'on_idle'<br>
  main.lua:276: in function <274><br>```

</274></.>

(danoise) #154

That’s pretty weird. I’ll look into it, assuming that you’re using the most recent version?

I know Adobe’s software can hogs lots of RAM, perhaps the computer was busy allocating resources or something.


(dby) #155

I’m pretty sure it’s beta 26.

Yeah, it’s weird, Illustrator wasn’t running in the background or anything. But it was the only change on the laptop since last time I could think of.

Still, it feels like I need a more powerful computer to run GridPie safely. Looking in to Ableton again, but there is soo much I don’t like about it. I really wish a more cpu friendly clip launching would be added to Renoise natively. Really need to get this live performance thing on the road.


(danoise) #156

Haha, yes I’m sure you are not the only one :slight_smile:

As for Grid Pie, how complicated is your setup - how many tracks, how long patterns, how much CPU usage (without Grid Pie running) ?
Personally, I rarely use more than a few tracks, and 128 lines in the patterns. Try to keep the tempo down, as much as possible too.
Automation, envelopes are replaced with creative use of LFO devices too.

If I need more than this, I would simply fire up another instance of Renoise.


(dby) #157

CPU stays around 20%, and I rarely see it go much higher, not above 30%. Current song use six tracks and 256 line patterns. Tried shortening to 64 lines and also erased a bunch of patterns, but didn’t notice any difference in performance.

Guess I could change Lines/Beat from 16 to 8. Or even slower. I only wanted to use 16 to get good maximum speed on the LFO’s.


(dby) #158

I changed LPB to 8 and shortened patterns to 128… seems a little bit more responsive now. Guess I’ll give a Renoise live set another go, I just panicked a bit. Clip launching is the only thing Ableton does better than Renoise imho.


(dby) #159

Is there any way I can get GridPie to start up, ready for action after I load a song? During a live set, I’d like to load a song and press play on the monome and not worry about anything else. I’ve been fiddling with some options like “display on startup”, “autostart configuration” and “initialization” but haven’t been able to get it to work yet. Usually the problems are GridPie needs to be restarted and “follow” is then switched off somehow.


(dby) #160

Another problem when saving/loading a song with GridPie running…

I need to remember to unmute the slots in the first pattern. If I forget, my midi hardware gear won’t receive initial state from the Instr.MIDI Control device.

Also this kinda transfers to other songs I load after that, even if they were saved with GridPie switched off or running with first pattern unmuted. I need to switch GridPie off and then load a new song.