New Tool (3.1.1): KangarooX120 v1.1 build 030


(marbangens) #21

When I do that notes still goes to track 01?
Renoise just place the notes in the track the cursors at as usual


(Raul (ulneiz)) #22

Look carefully at the values stored in each pad. Each pad has 3 lines of information:

  1. Number or index of the pad.
  2. Note value | instrument index.
  3. Track index.
    and…
  4. …to the right of the pad: volume/velocity value (plug switch with “V” disabled)

A example (pad pressed):
KangarooX120-pad

  1. Index of the pad: 43.
  2. Note value: D-4 | Instrument index : 08.
  3. Track index: 05.
  4. …Volume/velocity value: 5F.

You must press the corresponding pad, not the piano. KangarooX120 are two virtual instruments for playing, the lower virtual piano and the upper 120 pads, which work separately.

The best thing is that you make a complete mapping of your MIDI pad with the pads that you want to use. Which MIDI pad are you using?


(Raul (ulneiz)) #23

KangarooX120-x16-Red%20Tr01-Tr06%20C-4

In this case I am saving a bank called “x16-Red Tr01-Tr06 C-4”, in which I have configured the red area of 4x4 pads, to always fire the note C-4 of the instruments 00 to 0F so that they record on tracks 01 to 16, with the same volume level 5F.

Each bank will always save all the configuration of all 120 pads. Go to the following path:

C:\Users\MY_USER\AppData\Roaming\Renoise\V3.1.1\Scripts\Tools\com.ulneiz.KangarooX120.xrnx\banks

and copy and paste these bank: bank_10.xml.txt (13.9 KB) (…delete the extension “txt”, it must be an xml)

Close and reopen the bank panel. The new bank 10 will appear.

Now you can load the bank 10 (press “Load 10” button).

Note: I will ask @taktik to be able to share XML files and ZIP containers directly in the forums.


The zoom window image work correctly?
(marbangens) #24

well this tool doesn’t work for me I tried like for a week now, like 20 times. I loaded that bank and I can’t change track number on the red pads like I used to, this tool have no effect. sorry.
Could this be just some typo bug or whatever that can be fixed? I would like to have this.
Also when I click on the knob(not the colored part) is it supposed to play the sound of the instrument connected to that pad?


(Raul (ulneiz)) #25

@marbangens I’m sorry that you can not make it work. It seems that you have serious problems with the tool. Is it possible that you have not activated your OSC? I have taken for granted at all times that you had it activated.

I re-copy part of the instructions for use that are described in the comment #1:

2.- OSC & PREFERENCES . Enable OSC in “Renoise: Preferences/OSC/…”. Invoke the KangarooX120 tool. Then, show the preferences panel with the preferences button of the tool ((KangarooX120: press “RETURN”) and follow the instructions to set the configuration.

image

Make sure to use the same port 8000 with the protocol in Udp. Without the OSC, the tool “does not sound”, rather, Renoise “does not sound”. OSC is the communication protocool between the tool and Renoise.

KangarooX120 v1.1 build 030 works correctly. Make sure you use this version.

Yes, you can play the 120 pads with the mouse pointer or through the MIDI keyboard/pad controller, correctly MIDI mapped (the instrument, the note, the track and velocity configured). When you check the OSC settings, re-read the instructions above and try again. I assure you that this tool works correctly, very fine in addition.


(marbangens) #26

I tried with OSC 8000 with the protocol in Tcp
It behaved different but don’t work


(Raul (ulneiz)) #27

What operating system are you using, and what version of Renoise are you using?

It would be nice if you copied a screenshot of your configuration…

You should be able to do this:kangarooX120-touch-pad

Edit: If any of your instruments “does not sound” after correctly configuring KangarooX120, maybe it is because the samples of the instrument are not properly configured. That is, if you play a routed pad with the instrument 03 for the F#5 note, this note must have an associated sample in the instrument. Otherwise, the note will not return a sound. That is, in addition to correctly configure KangarooX120 (which is only compatible with version 3.1.1 of Renoise), you also have to check that your instruments in Renoise are well configured (do not play a note that does not have a sample associated. The same for VSTi instruments).


(marbangens) #28

There is no samples its an vst instrumen.
I use windows 7


(marbangens) #29

I could try record my desktop


(Raul (ulneiz)) #30

If you do not want to make a video, you can use the program LICEcap v1.28 to capture the screen in an animated GIF.

I also use VSTi instruments (orchestral libraries). I have no problem with KangarooX120. Everything works correctly.

The KangarooX120 tool should work exactly the same in Windows 7 as in Windows 10.

Actually, the tool does not care if the instrument is a native one with samples (an XRNI) than a VSTi. The issue is that the instrument must be configured correctly to reproduce the corresponding notes, those reproduced from the tool. You can use the lower virtual piano to play an instrument while the other pads play the associated notes, as if you were playing two separate things. It is best to map a MIDI controller keyboard for the lower virtual piano and a MIDI pad for the pads, both sensitive to the velocity of the pulsation.

One more detail. Renoise has a problem currently with OSC and the undocked window of the instrument editor. If you have the Renoise instrument editor window separated, OSC can not send the messages from note_on, note_off to the pattern editor. Therefore, the tool will not work correctly. @Taktik already knows about this problem and will supposedly fix it. I mention it to you because this scenario can be the cause of not playing / recording the notes correctly, and this is a Renoise problem, not the tool. This problem affects all the tools that use OSC.

For the tool to work properly, you must have the instrument editor anchored, without a floating window.


(marbangens) #31

I diddent have floating window. It behaves diffrent every time I use it, but on linux it had an effect. it made dubble notes. still on the same track… click on pad dont make sounds


(Raul (ulneiz)) #32

I can not test in Linux, but it should work just like in Windows, since the API is the same. You must have correctly configured the OSC and the corresponding port open for the notes to sound.

Yes, you can record a multitude of notes at a time by playing several pads at the same time with MIDI Input.

To rule out problems, test with native XRNI instruments, instead of using VSTi instruments.


(assink) #33

This… is exactly what i was looking for… i wonder why i never tried this tool before… Thanks for this!


(marbangens) #34

forget linux, here on windows I have OSC configured like Tcp port 8000
and I try with native instruments now I get double note in tow columns on windows to.
what about the Oct value can it fuck it up?
so it works for everyone else but not me…
but I still don get the sound when i click on pads


(Raul (ulneiz)) #35

Enjoy it!


(Raul (ulneiz)) #36

Can you post a video to see what happens? I should show the tool and Renoise.

When you press a pad, the note that the tool should touch depends on what is written on the pad.

You can monitoring the OSC messages here: Edit/Preferences/OSC. See what happens in the message panel. When you press a note, and you release the same note, it appears:

/renoise/trigger/note_on (4 arguments)
/renoise/trigger/note_off (3 arguments)

These two lines should only appear once every time you play a note.
image
To send messages: Protocol Udp, Port 8000


(marbangens) #37

I got it without the sound but you can see the sound
you need to select better quality

(Raul (ulneiz)) #38

Ok, in Renoise / OSC, you always have to use the “Udp” protocol (it must be the same as in the KangarooX120 preferences panel). I will add the instructions more specifically to avoid confusion in comment # 1.
image

Note: Be sure to place the valuebox in “PAD” when you finish assigning the pads. Otherwise, when playing the lower virtual piano, you will be assigning the selected pad again.

The notes you record at the end of the video are not recorded by KangarooX120. To use the MIDI input, be sure to correctly map the tool, using the specific MIDI channel.

image
For MIDI Input, select Renoise and Press CTRL + M and assign the controls…


How to assign a MIDI controler pads for selecting instruments
(Raul (ulneiz)) #39

@marbangens, Just one more tip:

Watching your video, it seems that you want to use only one sample for each instrument. For example, your instrument 01 (the second), only has the note D-4 assigned to the Keyzones.

The advisable thing is, if you want to play a drum kit, use only one instrument, for example the 00, and in it you include all the samples of your drums (snare, kick drum, cymbals …) assigned correctly in the keyzones.
In this way, you can play instrument 00 on the same track, or play the notes of instrument 00 on different tracks, as long as you do not use the effects of the instrument editor (“Create FX chain”).

Always make sure to use the Keyzones correctly, to avoid touching a note that has not been assigned a sample.

If you set everything correctly, you should not have any problems, but you should know what Renoise and KangarooX120 are doing at all times.


(marbangens) #40

It works now when I hit the pads. I get notes in the tracks I want. I think I get it :smiley: thank you :smiley: