New tool (3.4.1 ) ReSpeak TTS

Hello,
I put it in the wrong forum before.
ReSpeak is a graphical extension to the TTS program Espeak.
It is an offline text-to-speech converter.
I think no further explanation is needed, the controls are sparse.

ReSpeak

cz.martblek.ReSpeak_v03.xrnx (4.6 KB)

v0.03

  • Run on Win10 tested directly by me.
  • Espeak, the path to the binary is currently saved with the profile settings
  • The base path is set globally to “espeak” for easier running on Linux
    and also Win for the one who has the path variable set.
  • Removed deleting created samples by espeak. Now is temporary file used.

I ask Win users not to install espeak in a directory whose path contains spaces.
The tool will then not work.Yet

cz.martblek.REspeak_v02.1.xrnx (5.1 KB)

v0.02.1

  • missing line for saving text :frowning:

v0.02

  • added buttons for executable file and temporary sample storage selections.
  • the ability to keep the created wav file from espeak
  • creating one or more samples for the instrument
  • resolved an issue with loading into a multiline text field

cz.martblek.REspeak_v02.xrnx (5.1 KB)

Still tested on Linux, No Win or Mac here.
Every language and voice is set according to my setup for espeak.
Some languages and voices may not work for you.

3 Likes

Unfortunately still doesn’t return a .wav in Windows;
image

I have tried directing the tool to the commandline executable and also to the main program executable, both will give the same error. Anyone else on windows 10 have gotten this to work?

hello,
I would like to help but unfortunately :frowning:
I think there will be problems with text string conversions.

1 Like

Hello,
I installed win10 on free partition for tests.
Espeak in cmd works but does not create .wav files.
“espeak ‘test’ -w out.wav” dont create any file
I tried to work around this by redirecting the output to “espeak --stdout ‘test’> out.wav”.
This works but Audacity does not load the resulting output.
(It’s weird that in Linux this sample will handle Audacity without any problems, but no longer Renoise → unexpected end of file).
I can’t think of anything else, there’s nothing about this problem on the espeak forum.

Hi,
I think the problem is solved.
Incredible windows feature :frowning:
Update soon.

1 Like

ReSpeak 0.03 is out.
Scroll up.

1 Like

image

I’ve changed the name manually in the scripting terminal and have gotten the tool gui to show up, unfortunately no .wavs are generated. I keep getting;
image

I will try to move the .exe around different folders to see if this fixes things.

hi,
what is path to your espeak executable?

sorry in previous versions the name was REspeak and this changed to ReSpeak in 03.
in the manifest it’s all good, but probably the older version remained installed,
so uninstall REspeak.

“D:\PROGRAM FILES~SOFTWARE\eSpeak\command_line”

(somehow the \ between PROGRAM FILES & ~SOFTWARE is lost when copying the address to this forum) It directs to the .exe that’s in the commandline subfolder, but I have moved the installation folder around, also directly putting it in D:\ which didn’t work either. The tool gui gives a lot of choices of languages and voices, are they supposed to all work, or do you need to setup something in the actual program first?

hi,
on windows please reinstall espeak.
as i wrote above, path to espeak executable must not contain spaces.
if you manually move espeak instalation directory path to espeak_data disapears.
i installed espeak for test into C:\user\martin\desktop\espeak i think and everything worked.
Path without spaces is absolute necessary.
Voices: not all voices work on win. if voice dont work espeak use default.
If language is no supported then universal error appears

Thanks for the help! Finally got it to work, indeed fresh install directly into the main drive helped, instead of moving the installation folder around after install. Weird that a path without spaces is necessary, perhaps something can be learned from the other tools that send data to offline commandline .exe’s? Anywho, off to experiment with it! Cheers :sunglasses: :clap: :beers:

I like that you’ve added the “Select Executable” button, and I can find ALL of the hidden files in my Mac, but the eSpeak executable does not show up as an option that I can actually select. I can see it, but it is faded out. There’s no “.exe” or other suffix to make it stand out as a selectable option. :frowning:

eSpeak’s not my fave TTS voice, but having it IN Renoise would be awesome for Mac users. I can’t stand Mac voices, and they’re also not usable from a commercial standpoint. That’s why I use DECTalk and MaryTTS.

Hello,
Can you try to change the filter on line 364 in main.lua ?
select

I can change it, but the issue is, there is no extension to the file name. it’s “espeak”. Because it’s a Unix file on OS X, there is no extension. I tried just using “espeak” in parentheses on line 364, but no luck.

that would be any mac specialty?
for me it works normally even without a filter.
select
select2

Yeah, sorry, it’s not the same - I wish it were :slight_smile:

Oh well. In any case, I’m cool with it only working for Linux/Windows. And, thank you very much for looking into this! Your work on these Tools is excellent!

Cant wait for osx! big up!

1 Like

I’d love to help you more, but I can’t install Hackintosh on this pc set.
Maybe I’ll try over the docker image
or a friend may lend me his old mac mini, but he is already very slow / the mac /.

2 Likes

this is it ?
osxerr

cant select too :frowning: but if i tried execute this program osx says something about old version and quit.
in qemu running Mojave.