Newly installed AU plug-in not showing

I have recently purchased PSP’s NobleQ. This plugin comes in two flavours: “NobleQ” and “NobleQex”. Both of these should be installed when you install the plugin package.

For some reason, Renoise is only showing “NobleQex”, and not “NobleQ”.

I have tried a whole range of things, but the AU component of NobleQ does not show even though there is “NobleQ.component” in the AU plugins folder. Here’s a summary of all the things I have tried:

  • Confirmed presence of “NobleQ.component” and “NobleQex.component” in the plugins folder.
  • Confirmed presence of plugins in Reaper: Reaper shows both NobleQ and NobleQex, authorised and functional.
  • Rescanned plugins from within Renoise
  • Deleted “CachedAUs_x86.db” and forced Renoise to recreate plugins database
  • Installed the VST versions: VST versions show both NobleQ and NobleQex. This problem is only affecting NobleQ.component, not the VST version. Strange!
  • Searching through the “CachedAUs_x86.db” sqlite file for clues. Can find NobleQex listed, but not NobleQ.
  • Contacting the PSP guys: they say they have no idea why just NobleQ would be failing to register in Renoise, despite the component file being there and also being accessible in other DAWs on the same computer.

None of the above seems to make NobleQ register.

Does anyone have any clues what I can try next?

Thanks for any help anyone can provide.

2009 Apple Mac Mini running Mac OS X 10.7.5
Renoise 32bit 2.8.1
PSP NobleQ 1.7.0 (latest)

Is the NobleQ perhaps using the same plugin ID as the NobleQex. My guess would be that if they would share the same ID, Renoise only will register one of both plugins in that case where it is expected each plugin to have a unique ID.

That sounds like a plausible explanation. Where does the plugin ID come from? Is that something that is set by the plugin developer? Is it anything I have control over?

I don’t know, the plugins found are stored in the CachedVsts.db in the preferences folder. With a mysql db viewer (firefox has an add-on) , you might be able to view the contents. You perhaps can also view the failedVsts.db and see if it ended up there instead.

Yeah, I’ve already tried searching through the CachedAUs database (as the plugin in question is AU) as well as the CachedFailedAUs database, and found no mention of NobleQ.

The suggestion of a plugin ID being the same, and therefore Renoise only displaying the second of the two (i.e. NobleQex instead of both NobleQ and NobleQex) seems very plausible. Does anyone have any other useful information about plugin ID?

You could remove the NobleQex, ditch the cachedAu.db and see if it will then detect the NobleQ to rule a double ID out. If it finds it, they most likely share it, if it doesn’t find the NobleQ at all, then there is something in the plugin that Renoise doesn’t get in a response.

Thanks vV! You were right!

As you predicted, removing just nobleQex.component and trashing CachedAUs.db caused NobleQ to be recognised! So this indeed confirms your theory about the two having the same ID, and therefore only one being registered.

So now that we know the problem, what is the solution? :rolleyes: Is the plugin ID something that is set by the vendor? Does anyone know this? I’ll fire off an email to PSP to ask.

I’m not sure if PSP can do something about it, but Taktik is currently on a holiday, so if PSP is able to answer about that meanwhile, would be nice to know what data is actually identical that doesn’t supposed to be identical or perhaps something is is interpreted as being unique that has no guarantee that this parameter will be unique at all.

Thanks vV. Any idea when Taktik will be back?

I haven’t yet heard from the PSP guys. Perhaps I will use the email support form in the meantime.

Thanks for all your help!