No Headphones Sound On Linux

Hi, I’m running renoise on my laptop on fedora 15 x64 and I’ve noticed that there is no sound when I plug the headphones or any other jack plug whatsoever.

I do have sound from the apps except from renoise, I’ve tried no real time, real time Alsa, and jack.

My laptop is an acer 5810T with the infamous Intel HDA, and as far as I’m concerned the sound switches from the speakers to the headphones digitally.

I’ve seen on other threads that idea of the 4 channels but I don’t know how to select the output channel in renoise because my options are:

Out Device:
hw 0:0 ALC269 analog
hw 0:1 ALC269 digital
hw 0:3 HDMI

Thanks in advance.

F15 and the Realtek/Intel HDA onboard chipset has worked fine with audio on my laptop. Well it worked through both internal and external speakers, although it did always have more hiss and distort far more quickly than under WinXP, but that’s separate to your problem.

When F15 is first installed the ALSA Mixer does seem to be set with most things Muted and not a single fader visible, so maybe you want to enable some of the faders within it and see if maybe there is something off such as headphone mode it might assume you’re in when you plug into the jack socket.

You running stock kernel? I’ve not got CCRMA to work yet!

Also, I use the XFCE distribution, not the default Gnome one. Which are you on?

OK. Just reread you post.

So using Parole/MPlayer (whatever media player you have) to play a wav/ogg etc and you get sound from both internal speakers and then your headphone when you plug them in, correct?

You start Renoise and you get audio through internal speaker, then silence ones you plug the headphones in? Even if headphones were already in use first?

And the out device you want is going to be hw0:0, the analogue one. You are not wanting HDMI and headphones do not work on a digital signal.

I have this problem too, exactly as krimen described. I’m running crunchbang on an asus eee-pc. Everything works beautifully except that when I plug in my headphones Renoise doesn’t output any audio. Other applications output audio to the headphones just fine.

The situation is the same with both alsa and jack. Nothing is muted in the alsa mixer. Very odd problem :P

fwiw, i’m running Crunchbang here on a ‘regular’ laptop (so no eeepc) and am having no issues with headphone in Renoise. you might consider asking on the #! forums, i suspect this is more of a Linux-issue than a Renoise one, but not sure at all :)

Same here. Ubuntu 11.04 64 bit.

All apps are working correctly with headphones except the Renoise.

ok, seems this thread has stalled a bit… was reading up on Linux audio, and re-read this thread. here’s what i’d try in your case(s):

  • run ‘amixer’ (terminal command); it shows you the setup of your mixer and you can see at a glance if thinks look proper to you. (i think they should, seeing how the headphones work outside of Renoise)
  • start Renoise from a terminal and check to see if it gives you any errors or whatever when you play something with headphones plugged in.
  • ask around on the forums of your distro; people there are a lot more knowledgeable on Linux usually, so they might have a solution (?)

again, these are the steps i’d take. i am not saying this will do you any good, i have no idea, but this is what i’d try at least.

I wrote it here because I havent found any other application which generates this problems - which makes me think that problem is in renoise.

Not sure about amixer, I am using alsamixer and all outputs are configured correctly.

About ‘forums’ and so on - I am not really in the mood to talk with open source developers / community and asking them about problem with closed source software, like Renoise.

But beside last step - first two of course has been done.

well that depends on your community i suppose. Colugo said he’s running Crunchbang. you can ask these questions on their forums no problem, they won’t make you go through that whole tedious open-vs-closed debate before you get an answer. so maybe we have to rely on Colugo for an answer from the Linux community…

i have no idea if the problem is Renoise or Linux, honestly, i think it could be both. it is a strange thing, so would be a good thing to see this resolved.