No internet connection via plugin in Renoise 3.4.2

Hi, just tried to activate my license for Baby Audio’s new IHNY-2 plugin in Renoise 3.4.2 on Win7, but the plugin fails to detect my internet connection (required for activation). I made sure to allow Renoise through my firewall, is there anything else I could try? Also sent a support ticket to Baby Audio, but not sure where the problem lies yet.

On my mac I had no issues activating it.

Perhaps the plugin is running a separate process that the firewall does not see as Renoise (or as coming from Renoise).

Perhaps the Defender Firewall log shows what has been blocked.

You might also disable the firewall long enough to get the plugin activated. Hopefully it won’t try to phone home on every launch.


Maybe in Renoise preferences you have checked Run all plugins in sandboxes?See if that helps


Thanks for the good suggestions!
But nope, did not work even when I disabled the Firewall, and nothing in the logs, and sandbox mode was not enabled.

So weird, guess I have to wait for a reply from Baby. Maybe they can offer some offline activation mode.

Maybe their servers are down or misconfigured but the error message doesn’t reflect that (i.e. if the vst doesn’t get a server response it assumes there is no internet).

Are you using a VPN? I self-host a VPN on a colo server, and certain sites use Amazon for a DDOS-shield, and often that middleman server blocks my requests because they don’t like the IP address of my VPN.

Hard to debug stuff like this.

Yeah I’m in touch with their support now, hopefully we will sort it out. I don’t use any VPN, and get same result no matter what wifi or mobile network I’m on.

I’ll update here when I have a solution, thanks for all your input!