No sound with ASIO4all


(june bug) #1

Hey all,

So after some much troubleshooting with using ASIO4all to get less latency with a guitar into my USB audio interface, I realize finally why I am getting no sound. The Master track is routing back to my audio interface. The audio interface is the only option to choose from the drop down menu in Master routing when I choose ASIO in preferences. Going back to DirectSound I hear everything properly, but it goes back to around 10-15 milliseconds of latency - no good.

If there a way to prevent the Master track from routing to my audio interface? Obviously not getting any sound from there. It needs to be set to Primary Sound Device, I suppose.

Windows 10, 64-bit. Renoise 2.8.0


(dblue) #2

Does changing the option “Limit to stereo in/out” in Renoise’s audio preferences make any difference?

If not, here are some other tips I found that may help:

http://www.sonicprojects.ch/obx/asio4all.html

ASIO can be quite picky sometimes depending on your audio interface, so it’s possible that your interface only allows a single application to use ASIO at any given time. So if you have any other apps open — web browser, mp3 player, etc. — then be sure to close those first.

It’s also quite possible that Windows tries to use ASIO4ALL as the default output, which will then steal control away from Renoise, so you should also double check those settings and set a different default output if necessary.