[Nobug] Mpreverb Killing Audio

Find attached the .xrns I was messing with to see if you can replicate the issue.

I have a fair amount of fast LFO stuff going on, and the last effect in the chain is an mpreverb.

In the saved .xrns I am sharing, it is currently turned off.

Start the track, then turn on the mpreverb. Does it totally lock out the audio, like it does on my machine?

Cheers for any help in advance.


on Linux here too, and it happens here as you described. the problem is with the volume. it locks up because it is clipping to shit, just look at the Mixer for that track when you turn on the MPreverb. sliding the volume down to 3 on the Mixer and to about 12 on the DSP-volume-thingy at the end of the chain, it doesn’t block out the audio.

now, as to exactly why it is clipping this much, and how to fix it, you’d have to hope for someone with superior audio-knowledge to join in this discussion. it is definitely not a bug though.

Yep. The audio gets completely overloaded here also, but I’ve spotted the problem immediately.

For a start, you’ve got devices like Phaser and Comb Filter in your chain, and both are set with relatively high levels of feedback. These devices alone will introduce some phase shift into your signal (Phaser is the main culprit in this case), and the high feedback will only amplify this further.

Then you’ve got 8.640 dB of Low Gain boost on the mpReverb itself. This is amplifying the phase shift even further, basically causing it to completely feedback and overload the entire signal.

The result is this:
3134 renoise-mpreverb-phase.png

Steps to fix it:

  • Add a DC Offset device before the mpReverb and enable the Auto DC feature. This will help to keep some of the phase shift in check.

  • Set the Low Gain on the mpReverb to a negative value. Even -1dB is enough to completely solve the issue. Having a bassy, muddy reverb is always a terrible idea anyway, so I would personally reduce it even further.

Here’s a fixed version:

Sometimes it can be difficult to track down the source of the problem, but if you render it out and see the signal bending off to one side like that, it’s pretty much guaranteed to be a phase problem. Thankfully, phase problems are usually pretty easy to fix. ;)

Ah thanks a lot.

Yeah, I am aware that it was clipping to shit; that is how I work, for my sins! I get everything sounding like an actual song, then go back through it all with an engineers head on.

Well, thanks a lot for looking and glad that you were about to replicate the issue. I am also a bit miffed as to why it is clipping so much, and why the clipping caused the audio engine to shit the bed so hard.

Looking forward to someone being able to shed any light on this.


See above :)


Thanks a lot mate, that explains things very well. Will address the issue, and my working practices.