Note "off" Creates Click-Sound


I just created a bassline where the sample play shall be stopped by the “off” command. Unfortunately this creates a click-sound. When i set volume to 0 instead, there is no click sound. Is this how its meant to be?


this click-sound occurs when a note is cut at a point where there is still a sound, so to speak. the gap from sound to silence is big and you get a click. same kinda thing happens when you have a sample and paste part of it somewhere in the middle and the waveforms don’t align. not sure how to formulate this any better (dblue where are you?).
well, in short, it is normal behavior.

what you could try is setting the note-off a line earlier or later, and see if the click disappears. you could also try setting the sample cutoff (sample properties) to note-off, and setting an instrument envelope which has a gradual curve. you could also try switching on ‘autofade’ in the sample properties.

The envelope is the easiest and most effective solution. Just give the sample a little release and you’re good to go.

Hey rhowaldt and td6d,

thank you for the answers! :)

I know where these clicks come from, i just thought renoise might deal with it automatically. But the envelop is a very good workaround. So far i haven’t been working at all with envelopes for samples, i’ll check it out.


It used to ramp down volumes but we got tons of complaints that this was messing up other situations where there was no way to control the behavior the way it was.
So it got reverted again.So you can control using envelopes or volume value entries before applying the note off when necessary.

Hello vV,

i think then it’s straightforward. The envelopes work very good and i think they are fantastic. Now samples become more editable for me, they are now more like instruments, like i can shape synth sounds.