Open an XRNS File change Renoise windowstatus?!

Hello together!

I do hear some Renoise Competition Songs at the moment and i get aware that my Renoise Programmwindow changed the window status from maximized to normal. (what is very smal, aprox. half of the screen)
When i Renoise startet over the Desktop icon it start always with Window maximized. (with Taskbar visible)

The unwanted behaviour only occurs sporadically when i doubleclick to load a songfile or themefile on an external explorerwindow.

Anyone has the similar problem maybe?

I’m on Windows 7 last patchstand. I know it’s not supported officially anymore, but maybe it can be an problem on later windows versions too.

happy tracking :slight_smile:

Ok, i tested furthermore to can reproduce this faulty behaviour and can reproduce it now. Its not sporadically, its permanent!

Steps to reproduce.

  1. Start your Renoise (should be open as maximized window)
  2. minimize Renoise over the window minimize icon on right upper side
  3. open windows explorer (i have song directory on my desktop)
  4. double click on a XRNS Songfile to load it.
  5. Renoise Window will show unmaximized (tada…)

I think this is a Bug.

happy tracking :slight_smile:

Confirmed also for WIn10. But without step 2 it remains maximized after loading a song by double clicking on the file in Windows Explorer.

1 Like

If you want Renoise to remain in the maximised state, then do not minimise it? (Skip step 2 as @TNT says)

Rather… simply Alt+Tab out to Windows Explorer, double-click your XRNS song, and then Renoise should remain maximised.

Or (probably the better option) perhaps just use Renoise’s own built-in Disk Browser and avoid this problem completely?

Load Renoise, maximise Renoise, use the Disk Browser to stay within Renoise, load your songs, everything should be cool :slight_smile:

Then Renoise should be restarted in minimized condition (last window state) and when i click on the tab in the taskbar it should recall in maximized windowstate! That there are other possibilitys or workarounds to avoid this, dosen’t play a role. Its not clean window handling and unwanted behaviour.

happy tracking :slight_smile:

This could be fixed with 1 more config values. It needs saving the status before minimizing, which can be normal or maximized. Lastwindowstate in this condition would be minimize then. So only initialise Renoise with Lastwindowstate(minimize) and recall(before_minimized state) when click on Taskkbar tab. Or much easier open Renoise always in maximized state (make a config entry for this). Problem fixed!


Same behaviour, when you click “Show Desktop” on Windows Taskbar!

Why you delete your last post? I cant read em all complete!

By the way…

From Coder sight the right way would be to use a file mutex or named pipe to check if there is already a running Renoise instance and overgive the file param to load with that instance. Then there were no reason for closing Renoise everytime. I programmed such function often and use it in my own programms.

happy tracking :slight_smile: