Opening an XRNS from a network drive

Hi guys,

The second I try to open any xrns from my Synology network drive, I get this : whYBvnO.jpg

The certainly does exist. I’m not sure if this is more a windows or network problem but the error sure is weird.



FWIW I’ve had no trouble loading xrns files from networked machines, including assorted combinations of Win7, OSX something, and Ubuntu.old

There have been times when Ubuntu Renoise did not see symlinked folders in its file browser. But anytime I’ve been able to find a file it was able to be loaded.

What happens if you drag-and-drop from the network drive onto Renoise?

Drag and drop is how I get this error. My network drives are correctly mapped to windows drives, namely as O: P: and Q: however they don’t appear in Renoise as drives. I’m not sure theres the possibility of specify a network path in the Diskop but if there is I’m still searching. The only way I can open the files is to first copy them on a local disk :confused:

hah, make le music backup on google drive, works perfect in any place : D

Just to give you an update, I have changed my NAS in the meantime, I’m now on QNap which is very badass indeed.

I mapped my network music drive in windows to M:\

Not only does the drive not show in Renoise, but I also get the same “file does not exist” alert when I drag drop the file. I’m on W8.1, on Renoise 3.1 rc

Does anyone have a clue what could be done?

Are you maybe running Renoise as admin? Network locations can sometimes not be shown in programs when you run them as admin, or when the network link was created as admin and you are running a program as regular user.

It’s, well, complicated, but as usual MS offers an option in the registry to fix or workaround this. See please. Does this work for you, or NOT running Renoise as admin?

Hey man!

You are absolutely right, it was because of this. I ran Renoise as Admin because of Read only vst folders, but the minute I remove the admin attribute everything worked as planned.

However when I go in myC:\Program Files\sound folder and I change the VstPlugins folder permissions by unchecking the Read-only (including sub folders), the setting appears to be applied correctly, but when I open the properties again the box is checked again. And when I run Renoise I get the same warning about write permission to the VstPlugins folder. I am using my Admin account for this pc. Thats why I was forced to run Renoise as Admin in the first place, it was the only way I found to override this problem. :confused:

Hey. You can either move your plugin’s folder out of the system protected “C:\Program Files” folder, or give yourself the permission to fully access the VST folder and all subfolders. Disabling the “read-only” flag won’t do the trick here.

Instead, try:

  • right click on your VST folder in explorer
  • select the “security” tab
  • click on “Edit”
  • select your user in the list above
  • enable/select “Full control” in the “Allow” column

Hey Edouard,

thanks for the info! I followed each step but I still get the permissions nag. I rescanned the VST folder from inside Renoise prefs but I stll get this nag, even though full control is enabled :confused:

The screen-shot lists permissions for “ALL APPLICATION PACKAGES”.
Make sure you select your user (Shaypah) in the list above, also when changing the permissions.