Osx 10.7.3 64-Bit Running Logic Pro 9 (32-Bit) And Renoise 2.8.0 B8 Re


i have tested Logic 9 (with both 64- and 32-bit) in ReWire mode together with Renoise and i seem to have the following issues.
Everything runs under OSX 10.7.3 in 64-bit Kernel mode:

  1. Logic 64-bit (rewire master) + Renoise 64-bit —> WORKS
  2. Logic 32-bit (rewire master) + Renoise 32-bit —> Renoise is started second (as usual) but never finds the ReWire host. After start i am asked for admin password, to start ReWire mode. - I do enter correct password, but it never detects the Logic host.

It is completely reproduceable. A reboot doesn’t help, also tried restarting both apps 5-times didn’t solve the issue.

Due to the fact, that most audio plugins are not yet 64-bit, working in 64-bit in Logic is a pain in the ass because of the 32-bit plugin bridge and it’s confusing way of working with plugin windows… so it would be really nice to have Renoise + Logic working in 32-bit mode, too.

If you need further testing, please let me know.

Thank You.

p.s. when i run Renoise 2.7.2 together with Logic in 32-bit mode, it immediately recognizes the rewire host. - It also asks for admin permissions to initialize ReWire …


Try starting Renoise once without a master so that it can properly install itself. Then start the master and Renoise again.