OSX: All plugin UI texture images are all upside down in latest Waves 12 update

Halo World, I just updated my Waves to 12. It did open but the plugins are upside down.



it is upside down…it’s soo weird… In Logic it’s good… Waves 12 plugins, you can now resize the thing…

Do you use Waves? don’t update yet to 12 if you’re using RENOISE to produce and mix.

Don’t you have the old waves file? It’s a single file for all your plugins. I have 2 loaded so I can also use my old maxxbass plugin without upgrading it (gna gna)

It is working in Windows… Have you tried, “closing all apps, deleting cached vst’s in the Renoise pref. folder, deleting any previous, “waveshells,” and restarting the computer?”

Waves = such a pita, but working here… v12Waves12

The v12 plugins are working here on Windows & Renoise 3.2.2, the UI is the correct way up and…

… actually, no, I am having problems. After launching Renoise a few times today, I now get an insta-crash as soon as I instantiate a v12 plugin (I’m mostly testing with Berzerk Distortion Stereo & Reel ADT Stereo). I can still instantiate v10 and v11 plugins just fine. It’s as if something is persisting between Renoise sessions, do the Waves DLLs stay loaded in memory or something? (Just tried a reboot, that didn’t fix it either. Going to try the delete caches / rescan thing yet again… that seems to have got it working again.)

I did find that if I change the HiDPI settings on a Waves v12 plugin (in either direction), I can’t reload the plugin after changing it. I had to restart Renoise, and then the setting for that plugin would work.

I think I encountered the same problem on macOS: all texture images are all upside down.

The screenshot below is how Waves Element looks like when it is opened in Renoise 3.2.2.

Waves Element V12 in Renoise 3.2.2

Although it looks scary, those knobs and sliders are actually still on the same position and operatable as well, so once you know which knob or slider is for which function, you can still get expected result or sound.

I have same problem on macOS 10.13.6 & Waves 12.0.11.
Screen Shot on 2021-01-05 at 13-14-39

I’ve tried to remove preference plugin db files then restart, reinstall waves plugins but I couldn’t solved.

Only Renoise(3.2.4 / 3.3)has this problem…(I tried other DAW such as Live, Reason, MPC2)