OSX: Input glitch keeps happening

Hi there! I’m new to these forums so if I screw something up lemme know.

I have been trying to do live MIDI devices through an audio interface to Renoise’s input. However, in the middle of recording something there has always been some kind of input glitch that keeps happening. It lasts for a few seconds, but after this happens the instrument is completely off tempo.

I have tried to adjust every setting I could with MIDI and the input settings since I thought it had to do with either MIDI or audio latency, but this problem always keeps popping up no matter what, so it’s not that. This isn’t a unique problem to my audio interface either, as I have tried a cheap RCA to USB input as well and it happened there too.

Is this a common problem with audio inputs within Renoise? Is there some kind of setting that I have to adjust? If not, is this a problem with input or is my machine’s CPU just too slow?


Sounds like buffer underruns to me.

What are your audio settings? (maybe post a screenshot)

What interface are you using? (someone might have had similar issue with the same hardware)

What are your hardware specs? (cpu, gpu, OS including build, etc.)

The above information would go a long way to helping others narrow down the possible causes/solutions.

I have a 2015 Macbook Pro running macOS
Version: 10.14.6
CPU: 2.8 GHz Intel Core i7
GPU: AMD Radeon R9 M370X
Like I said, the issue isn’t the audio interface itself, but just in case if it’s needed the audio interface I use is a Focusrite Scarlett 3rd Gen 4i4, used for both MIDI I/O and audio input
Screen Shot 2022-09-27 at 11.33.33 PM
The Multi-Output device outputs to the Macbook’s built in speakers/default output as well as BlackHole 2ch

Screen Shot 2022-09-27 at 11.37.27 PM
MIDI Preferences just in case

The Clock Out goes to my Behringer TD-03, but I’ve had the same issues when it doesn’t go out to anything.

Hope this all helps