OSX: Latest Isotope vsts crashes when used in Renoise

Loading up an Izotope Ozone 8 plugin crashes when you try to tweak the plugin in Renoise.

It works fine in Reaper and Ableton.

OS: macOS Mojave 10.14.6

EDIT: Not just Ozone 8, RX7 also crashes.

1 Like

Please menu Help and from there show the Log file…

quote the section that is related to the specific crash of Renoise.

Mac Crash Report

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGILL)
Exception Codes:       KERN_PROTECTION_FAILURE at 0x00007ffee92eeff8
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Illegal instruction: 4
Termination Reason:    Namespace SIGNAL, Code 0x4
Terminating Process:   Renoise [20775]

VM Regions Near 0x7ffee92eeff8:
    MALLOC_SMALL           00007fd936000000-00007fd939000000 [ 48.0M] rw-/rwx SM=PRV  
--> STACK GUARD            00007ffee5aef000-00007ffee92ef000 [ 56.0M] ---/rwx SM=NUL  stack guard for thread 0
    Stack                  00007ffee92ef000-00007ffee9aef000 [ 8192K] rw-/rwx SM=SHM  thread 0

Application Specific Information:
BUG IN CLIENT OF LIBPLATFORM: Trying to recursively lock an os_unfair_lock

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_c.dylib             	0x00007fff7459aff4 __v2printf + 12
1   libsystem_c.dylib             	0x00007fff74580b03 _vsnprintf + 410
2   libsystem_c.dylib             	0x00007fff74580b60 vsnprintf_l + 41
3   libsystem_c.dylib             	0x00007fff74571a85 snprintf + 156
4   libsystem_c.dylib             	0x00007fff74531a40 _backtrace_snprintf + 153
5   libsystem_c.dylib             	0x00007fff74531960 backtrace_symbols + 264
6   com.renoise.renoise           	0x0000000106d015ea 0x106111000 + 12518890
7   com.renoise.renoise           	0x00000001069d719c 0x106111000 + 9200028
8   libsystem_platform.dylib      	0x00007fff746d1b5d _sigtramp + 29
9   ???                           	0x00000001089fbe00 0 + 4439653888
10  libsystem_c.dylib             	0x00007fff7458c6ac exit + 48

Renoise crash log snippet. Crash. Info just repeats.

CrashLog: 64 libsystem_platform.dylib 0x00007fff746d1b5d _sigtramp + 29
CrashLog: 65 ??? 0x0000000106b0ca00 0x0 + 4407216640
CrashLog: 66 libsystem_c.dylib 0x00007fff7458c6ac exit + 48
CrashLog: 67 Renoise

Are the Isotope plugins crashing for anyone else?

Using macOS Mojave 10.14.6 on a 2015 MacBook Pro with no issues while using: RX5 plugins, Neutron 2, DDLY, Neutrino, and even a few RX3 plugins. Haven’t tried Ozone inside Renoise in a while, though.

I don’t have a mac so this is probably not very helpful, but on the latest Windows 10 Ozone 8 is working fine in Renoise 3.2.

Are there any options to disable at the plugin that fix this issue?

Plugin Compatibility Options

3.2 plugineffects-compatibilityoptions.png

This dialog will appear after clicking on the 3.0 plugineffects-compatibility.png button in the plugin properties after a plugin instrument is loaded. In most cases these options will already have the correct settings, as Renoise comes with a database which sets the defaults for you. If you are experiencing any of the problems described in the dialog, then you might want to try altering the settings.

Yeah no matter which option I go with. The plugins still crash the moment you click on the plugin GUI.

Crash still persists.

If anyone wants to try and replicate this, you can get iZotope’s Imager plugin for free.

After you get the plugin, load it up in Renoise, and just try to go to a different window or move a knob.

Renoise will crash.

Does the plugin crash in other D.A.W.s as well?
It would be good to test this.

From first post.

oops I did not read the first post again…

Well… we have something for the developers to look at then…

@taktik are you reading with us?

LIBPLATFORM: “Trying to recursively lock an os_unfair_lock”

1 Like

I am having similar issues with tone2 firebird no matter what settings I choose.Does not crash Renoise probably because I have run plugins as separate proccess but crashes it self.Didnt have any problems in Renoise 3.1

Just installed that Ozone Elements they are fobbing off on people and it crashed Renoise the moment i clicked the GUI. OSX 10.11.6 on a Macbook Pro.

Checking that DDLY works… nope, crashed Renoise also:

“unhandled exception in thread: GUI”

Ok, running these same two plug-ins with sandboxing on seems to work fine. So it must be something to do with having them in the main thread, GUI issues. If they open a secondary window for options or what-have-you it’s a guaranteed crash.

Tried that on two different OSX systems now (OSX 14 and 11) but can’t replicate the crash with Ozone 8 Elemental and also not with iZotope’s Imager.

It’s weird that this produces different crashes on two different computers though.

Either way, it looks like the plugin is crashing and Renoise isn’t directly involved, so it definitely doesn’t hurt to notify iZotope, so they can look at this. Maybe they have an idea what’s wrong here.

@LegendaryTaunt and @cupcake:
Could you please report this to the Izotone support crew? As long as I can’t replicate the problem I unfortunately can not provide more info than you already did.

Strange that you can’t replicate the bug. Is it the possible fault plugin if said crash doesn’t happen in other daws on the same machine?

Regardless, I’ll contact iZotope today. Hopefully they don’t reply back with an “It works on my machine so I guess it’s no us it’s them” (no shade at you man. Just a lot of that happens in tech a lot unfortunately).

Let’s see what they say.

I’ll also completely uninstall and reinstall the plugins to see if there are a change.

Steps to reproduce on my system:

Open Renoise

Create Ozone Elements plugin instance

Click on settings button (gear symbol)

Either crash happens instantly or as soon as you click one of the drop-down fields on the secondary window. Check boxes seem to work ok.

Happens with DDLY too in same way

Does not happen on Imager as there is no secondary window to open

EDIT : tested same procedure on Ableton Live 9 and no crash occurs. Both Ozone and DDLY happily let me open the settings window and click as much as i like on all the drop-down fields.

I’m testing on a system where Ozone Elements was a fresh install as of yesterday (have never had any instance of Ozone on my computer), and DDLY has been installed for at least a year and must have been scanned by Renoise multiple times, although i do not use it all that much.

Just checked: crash happens as i describe above even using Renoise 3.1.1

Definitely the drop-down menus - check boxes and sliders appear to function correctly and do not cause crash.

EDIT: Just checked the preset browser drop-down - clicking causes crash on Ozone. Will e-mail you the log file. Sandboxing the plug-ins allows clicking drop-down menus with no crash resulting. So will keep sandbox on for the moment.

How do you sandbox a plugin again?

Yeah that’s how it’s happening on my end too. Same steps to reproduce.