OSX: Monterey - Renoise Won't Load

Hey, just updated my mac to Monterey and Renoise no longer loads.

It comes up with the loading screen and gets stuck on “Loading song ‘TemplateSong.xrns’…”

I can’t be the only one to have this problem, assume it’s just to do with the OS update. Stupidly didn’t back up my hard drive before so can’t go back, hoping this will be fixed in a future Renoise update…? Or anything I can do now to make it load?

Thanks…!

Things to try. Im shooting in the dark.

  1. File permissions of app manually or by something like Permissions Reset 2
  2. try to load by double clicking any of previous songs, so it will skip templetesong

If I try to open a previous song directly it still tries to load the template song first, so still gets stuck. Do you know where the template song is saved…?

Could you please post the Renoise log file here or send it to support AT renoise?
It may give us a hint of what’s going wrong here.

Sure, how do I do that?

The Renoise log file can be found in your users “Library/Logs/” folder and is called Renoise.log

If you can’t see your user’s library folder (Apple doesn’t want you to see it by default), see here for a little howto please:

OK great thanks, I figured it out. I read the log and it was one of the plugins in the template song which Renoise wasn’t able to load, I removed it from the plugin folder and Renoise loaded up the template song fine.

I guess the question is why that stopped Renoise loading altogether, I’ve had it before where I’ve tried opening old projects where one or more plugins are outdated and couldn’t be loaded but the project would still load, it would just say which plugins weren’t able to be loaded. Also seem to be some other errors in the log, not sure if they’re relevant.

Here’s the log:

============================================================
Version : Renoise V3.3.2 (Mar 7 2021)
Date : 2021-12-07
Time : 00:42:29
OS : Mac OS X 10.16 (x86_64)

CPU: Found 2 enabled unit(s) with 1 core(s) and 2 logical processor(s) per unit. 2 cores, 4 logical processors are enabled in total.

Application: Showing the splash window…
Application: Initializing the API…

IPP: Detected CPU type: 0x46

CoreAudio: Enumerating devices…
CoreAudio: ======== device enumeration: 1 of 2 ========
CoreAudio:
CoreAudio: — Device Input information —
CoreAudio: Driver name: Apple Inc.: Built-in Microphone
CoreAudio: SampleRate: 44100.000000
CoreAudio: mFormatID: ‘mcpl’
CoreAudio: Flags: 0x 9
CoreAudio: Bytes per packet: 8
CoreAudio: Frames per packet: 1
CoreAudio: Bytes per frame: 8
CoreAudio: Channels per frame: 2
CoreAudio: Bits per channel: 32
CoreAudio: Device audio buffers:
CoreAudio: Number of buffers: 1
CoreAudio: – Buffer 0 –
CoreAudio: Number of channels: 2
CoreAudio: Size in bytes: 4096
CoreAudio: Total number of input channels: 2
CoreAudio:
CoreAudio: — Device Output information —
CoreAudio: Driver name: Apple Inc.: Built-in Microphone
CoreAudio: GetStreamFormat FAILED
CoreAudio: ======== device enumeration: 2 of 2 ========
CoreAudio:
CoreAudio: — Device Input information —
CoreAudio: Driver name: Apple Inc.: Built-in Output
CoreAudio: GetStreamFormat FAILED
CoreAudio:
CoreAudio: — Device Output information —
CoreAudio: Driver name: Apple Inc.: Built-in Output
CoreAudio: SampleRate: 48000.000000
CoreAudio: mFormatID: ‘mcpl’
CoreAudio: Flags: 0x 9
CoreAudio: Bytes per packet: 8
CoreAudio: Frames per packet: 1
CoreAudio: Bytes per frame: 8
CoreAudio: Channels per frame: 2
CoreAudio: Bits per channel: 32
CoreAudio: Device audio buffers:
CoreAudio: Number of buffers: 1
CoreAudio: – Buffer 0 –
CoreAudio: Number of channels: 2
CoreAudio: Size in bytes: 4096
CoreAudio: Total number of output channels: 2

CoreMIDI: Creating client ‘Renoise’…
CoreMIDI: Creating an input port…
CoreMIDI: Creating an output port…
CoreMIDI: Creating a virtual input port…

Graphport: Initializing Freeimage…

System: Using ‘/Applications/Renoise.app/Contents/Resources/’ as resource base directory…

GraphPort: Initializing the Font Engine…

System: Executing ‘/Applications/Renoise.app/Contents/Resources/AudioPluginServer_i386.app/Contents/MacOS/RenoisePluginServer --enumerate /var/folders/6j/fhz51np904s_1411c8nsj6fc0000gn/T/Renoise-0-69970/Renoise_TmpFile-0-0.tmp’

Exception: Failed to open the file for reading

AudioUnitHost: File IO error while reading the plugin bridge component list (Error: Failed to open the file for reading)

ReWire Slave: ReWire shared library is already installed and up to date…
ReWire Slave: ReWire slave engine is already installed and up to date…
ReWire Slave: ReWire Panel was initialized…
ReWire Slave: ReWire Slave mode failed to init (no master is running)…

ReWire Master: Successfully opened

Application: Start running…
Application: Loading the preferences…
Application: Init…

ScriptingTools: Initializing Scripting Tool: ‘/Users/peterfernandes/Library/Preferences/Renoise/V3.3.2/Scripts/Tools/com.renoise.Rubberband.xrnx/’…
ScriptingTools: Initializing Scripting Tool: ‘/Users/peterfernandes/Library/Preferences/Renoise/V3.3.2/Scripts/Tools/ledger.scripts.ConvertInstrumentNumber.xrnx/’…
ScriptingTools: Initializing Scripting Tool: ‘/Applications/Renoise.app/Contents/Resources/Scripts/Tools/com.renoise.ToolUpdater.xrnx/’…
ScriptingTools: Initializing Scripting Tool: ‘/Applications/Renoise.app/Contents/Resources/Scripts/Tools/com.renoise.UpdateChecker.xrnx/’…

DspDevices: Registering native DSP effects…

Audio Plugins: Searching for VST plugins in ‘/Library/Audio/Plug-Ins/VST/’

VstPlugs: Trying to instantiate ‘/Library/Audio/Plug-Ins/VST/WaveShell-VST 9.91.vst/Contents/MacOS/WaveShell-VST’…
VstPlugs: Plugin is a Mach-O executable…
VstPlugs: Loading bundle: ‘/Library/Audio/Plug-Ins/VST/WaveShell-VST 9.91.vst’
VstPlugs: Analyzing VST plugin ‘Waves: WaveShell-VST 9.91’, Unique ID:1802721110, Version:2400
VstPlugs: Instantiate OK
VstPlugs: CreateInstance succeeded
VstPlugs: Releasing /Library/Audio/Plug-Ins/VST/WaveShell-VST 9.91.vst/Contents/MacOS/WaveShell-VST…
VstPlugs: /Library/Audio/Plug-Ins/VST/WaveShell-VST 9.91.vst/Contents/MacOS/WaveShell-VST was released
VstPlugs: Trying to instantiate ‘/Library/Audio/Plug-Ins/VST/WaveShell2-VST 9.91.vst/Contents/MacOS/WaveShell2-VST’…
VstPlugs: Plugin is a Mach-O executable…
VstPlugs: Loading bundle: ‘/Library/Audio/Plug-Ins/VST/WaveShell2-VST 9.91.vst’
VstPlugs: Analyzing VST plugin ‘Waves: WaveShell2-VST 9.91’, Unique ID:1802721110, Version:2400
VstPlugs: Instantiate OK
VstPlugs: CreateInstance succeeded
VstPlugs: Releasing /Library/Audio/Plug-Ins/VST/WaveShell2-VST 9.91.vst/Contents/MacOS/WaveShell2-VST…
VstPlugs: /Library/Audio/Plug-Ins/VST/WaveShell2-VST 9.91.vst/Contents/MacOS/WaveShell2-VST was released

CoreAudio: Using SampleRate 48000 (requested: 48000)…
CoreAudio: Output device buffer size: 896
CoreAudio: Output device extra latency frames: 7
CoreAudio: Using Latency 18.666666 - MaxBufferFrameSize: 896 (requested latency 18.666666)…
CoreAudio: Opening Playback Device 0 ‘Apple Inc.: Built-in Output’ (1 Stereo Channels)…
CoreAudio: Enumerating Output Channel Names…
CoreAudio: Output ChannelName 0 → Left:’’ / Right:’’
CoreAudio: Allocating Input Buffers…
CoreAudio: Allocating Output Buffers…
CoreAudio: Output IOProc was successfully installed…
CoreAudio: Starting Device Apple Inc.: Built-in Output…
CoreAudio: Output Device is up and running…
CoreAudio: Up and running

CoreMIDI: Enumerating devices…

Application: Loading the template document…

MIDI: Loading MIDI actions from file ‘/Applications/Renoise.app/Contents/Resources/Scripts/GlobalMidiActions.lua’…

Osc: Loading OSC actions from file ‘/Applications/Renoise.app/Contents/Resources/Scripts/GlobalOscActions.lua’…

VstPlugs: Trying to instantiate ‘/Library/Audio/Plug-Ins/VST/WaveShell-VST 9.91.vst/Contents/MacOS/WaveShell-VST’…
VstPlugs: Plugin is a Mach-O executable…
VstPlugs: Loading bundle: ‘/Library/Audio/Plug-Ins/VST/WaveShell-VST 9.91.vst’
VstPlugs: Analyzing VST plugin ‘Waves: H-Delay Stereo’, Unique ID:1212302419, Version:2400
VstPlugs: Instantiate OK
VstPlugs: CreateInstance succeeded

AU: Trying to open plugin:‘kammerl: KKWarmDist’ (aufx:Wdst:Kmml)…
AU: Setup I/O…
AU: Plugin suggests routing: 1 inputs, 1 outputs
AU: Plugin suggests routing: 2 inputs, 2 outputs
AU: Plugin accepted routing: 2 inputs, 2 outputs
AU: Inputs: 2 (max:2) Outputs: 2 (max:2) in 1/1 busses
AU: Setup Rate/Blocksize…
AU: Initializing…
AU: Setup Parameters and Presets…
AU: Start running…
AU: Instantiate OK
AU: Trying to open plugin:‘Softube: Saturation Knob’ (aufx:satn:SfTb)…
AU: Instantiate FAILED (Caught fatal error)
AU: Failed to create the plugin (Error:-1)!
AU: Instantiate FAILED

Audio Plugins: Failed to open plug AU: aufx:satn:SfTb

AU: Trying to open plugin:‘Softube: Saturation Knob’ (aufx:satn:SfTb)…

The general advice is to wait until you are certain that your host DAW and all plug-ins are compatible before committing to an OS update if you want everything to work:

Softube themselves have stated they are not yet M1 compatible and that Monterey compatibility is pending:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.